Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Holden Cruze 1.8L 2012. 63k miles odometer (15-03-2020).
Joined
·
108 Posts
After reversing out of a parking lot and driving the right side tire over the gardens concrete 5-6 inch wall the right side makes a rattling sound when driving about 25mph on a road surface with bumps that are half an inch or less in height which could be square reflectors or asphalt cracks filled with tar.

I have to replace both sway bar links especially if I use the better metal design right?
 

·
Registered
Holden Cruze 1.8L 2012. 63k miles odometer (15-03-2020).
Joined
·
108 Posts
I managed to remove a sway bar link without raising the vehicle. It was not hard either.

Parked the Cruze on a level flat surface with the front side, of the front wheel you are working on, turned fully inwards so you can get into behind the tyre, on the firewall/dash side of the engine.

For the bottom nut removal of the sway bar link, laying on my side and holding the ratchet with M30 torx bit between the sway bar and control arm and with the other hand moving the 12 point spanner to loosen or tighten. Them ratchet spanners should make things much easier. Top one is slightly easier to remove despite the small work room.

If doing it this way, without raising the vehicle, remove the top nut first. If you can easily pull the top bolt on the link out of its mount hole on the strut, this means the wheels have equal pressure on the sway bar so it is ok to continue.

If you are not using identical sway bar links, they must be equal length, the same product (see below what happened to me) and if not you must replace in pairs. Remove both links before installing the new identical pair.

I noticed while removing the bottom link nut, it came off very easy. There was no resistance. It was loose! Plus the original link has no loose free play on the swivel bolts. They rotated tightly in the sockets fine (65k miles).

I had purchased an aftermarket sway bar plastic link for US$20 which at a glance looked identical, however it turned out to be slightly longer than the OEM link that came with the car! I could not get it on.

I cleaned the surfaces of the links hole mounting points and the original sway bar link bolt and nut threads with isopropyl alcohol on a clean rag. There was dirt in the threads, they are exposed after all.

I reinstalled the original link and tightened hard by hand. The 16 inch long spanners helped give the force to do this. The original plastic sway bar links used a 18mm bolt on my Holden Cruze 2012 1.8L.

Rattling noise driving over filled road cracks and tiny bumps has stopped. All that was wrong is the nuts were loose and reversing over the kerb loosened them more?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top