Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
2,822 Posts
Also want to note, that it does run good at times as well. It can run smooth for awhile then it goes back to jerking & then smooth & jerking & blue smoke.
My 2011 ECO 6MT acted like yours. Would run ok, lose power, blow blue smoke. It would clear up and repeat. Used/burned lots of oil. Had my car towed to dealer. First the dealer advised blown turbo. Then determined two pistons cracked. Car was at dealer for 2 weeks. So - turbo, all 4 pistons and cylinder head replaced. When I picked up the car it seemed to run fine. Really did not want to keep the car with a rebuilt engine, so traded for my current car.
 

·
Premium Member
Joined
·
2,822 Posts
Sounds about the same oil usage I had - blown turbo and a couple of cracked pistons
 

·
Premium Member
Joined
·
2,822 Posts
I am so frustrated now, my car sitting at a dealership two weeks & failed to really do anything expect keep my car on the lot & bill GM is basically all they did! Well enough venting & now wanting to know should I even try driving this car the full 40miles to the dealership so whats your suggestion's?
With the amount of oil you are losing/burning - get it towed. That is what I did when my car had the same symptoms.
 

·
Premium Member
Joined
·
2,822 Posts
Kinda went thru this on my car - first was told the Turbo was blown due to the oil line, then since the car was still smoking after turbo replacement, was told new head and pistons needed. My car never left the dealer - for 2 weeks. I picked it up and drove it maybe 15 mins and traded it for a new car. At least for those 15 mins there was no smoke and the car ran good. The sales guy that took my car said it drove fine for him.
 

·
Premium Member
Joined
·
2,822 Posts
You know w/ all that waiting for GM hey that is still fine. At least now we are starting to finally make some progress is great & the issue is finally looking them in the face :smile:
Just be prepared for a slow process. I know when I had my pistons replaced - the dealer advised any parts would go standard shipping - no overnight/next day delivery of warranty parts.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top