Chevrolet Cruze Forums banner
1 - 1 of 1 Posts

·
Epic Beard Man
Joined
·
5,388 Posts
This thread has convinced me that this Forum is a bad place to get advice. Too many experts who get it wrong too often. Poor joshuab gets told it is definitely a cracked piston or a sensor or the turbo but all along, he is giving us the classic signs of a messed up PCV system, which is a bit more complicated on a turbo charged engine than a normally aspirated engine. Then the foolishness starts about max "whatever" with the turbo at some low rpm for the automatic and some slightly different max "whatever" for the turbo with a manual shift setup. Why are we talking about max anything at 1850 rpm on a gasoline engine. Maybe on a big diesel. Your turbocharger starts to "spool up" (as pointed out by obermd) at probably 1850 rpm and then at some higher rpm (5000 maybe?) it is spinning at somewhere between 90,000 and 150,000 and giving max boost. joshuab - it is obvious you have Bad Karma and you need to get right with it. Volunteer at a Food Pantry or a Soup Kitchen or something like that and your karma will change to the positive. I am leaving this forum (I will figure out how to delete my account after I finish this post) and the people I will miss the least are NickD with his useless drivel about the past and XtremeRevolution with his dangerous posts about using any oil in your Cruzes that don't have the dexos certification. What's the big deal about this - just use dexos oil!! And oh, by the way, the main reason I am leaving this forum is that I don't have a Cruze anymore. Adios from the Eastern Panhandle of Tennessee.
You need some boobies to play with.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top