Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My injectors have gotten noisy in the past probably 5,000 miles. I have just over 51,000 miles on the car. I am also noticing some idle hesitation when pulling up to lights or sitting at lights. To me it seems like a partial misfire as if one cylinder isn't being fueled properly. It will kind of blub, blub, blub, for like a few seconds and when I hit the gas to go, it runs like butter. I have done a visual inspection of tubing, all fluids, plug gaps, air filter, MAF sensor, and belt tension-er. Is this a sign of some faulty/lemon injectors? I have been thinking about just buying some to take the noise out anyway, but I need some help before I spend $200.

Car Info: I do have the Trifecta basic tune (the latest Dec. update). Car is stock except for the snorkel delete. Using the stock style filter. I always run 93 octane at a Top Tier station.
 

·
Administrator, Resident Tater Salad
Joined
·
17,304 Posts
Injectors on these things are all noisy.

Could it be your Evap purge valve? Fat round thing at the back of intake manifold. Can make a lot of noise when it goes bad and cause hesitation off idle or hard starting. Unplug it and see if it's quieter.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Injectors on these things are all noisy.

Could it be your Evap purge valve? Fat round thing at the back of intake manifold. Can make a lot of noise when it goes bad and cause hesitation off idle or hard starting. Unplug it and see if it's quieter.
Okay. There are so many vacuum type lines in this car oh my gosh. I'll look into that.
 
1 - 4 of 4 Posts
Top