Chevrolet Cruze Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 · (Edited)
Hello, I have a 2013 Cruze LTZ with the full color touchscreen and navigation. Anyways I have an original iPhone 5 (not s or c) and there was an update done to it a few months back (10.3.3). Now every time I receive a phone call and answer it through my built in Bluetooth in the Cruze it will answer the phone and immediately transfer the call back to the phone itself. I have to manually transfer the call back to the Bluetooth every time.

I have had this phone and car for five years and it worked perfectly fine until this update. I tried another iPhone that had 10.3.3, and it had the same issue. When I tried my iPhone 3GS (really old), it worked fine. The real problem is that my phone will no longer have any updates since my phone does not support the current version 11. I read other forums and apparently this same issue was happening to BMW’s, but when they upgraded to iOS 11 (they had newer iPhone's) it resolved the issue (which I cannot do).

I have tried all the ‘normal’ steps. Unpair/ and repair the phone to the Bluetooth. Completely reset the phone. I even reset the radio on the Cruze, with no luck. I asked for advice on the Apple discussions about this and they said that the car probably needs a software update. They said that “vehicle manufactures are provided iOS updates to test their vehicles and they test to ensure their vehicles work with the latest Bluetooth profiles and iOS.”

So, this leads me here, are there any updates to the infotainment system of my Cruze? I have provided a picture of the list of updates that are currently on it. I wonder if this car has ever been updated since the factory. I have searched all over the internet and from what I read GM used to allow the customer to do updates through the USB, but now only the dealer can do it. Has anyone else had this issue with any phone?

Thanks in advance for your help.

IMG_0266.jpg

Just an update, this it is definitely the car that is causing this issue. I tried the same phone in a 2013 Nissan Altima, and it worked fine. Also I tried chatting to GM online and their only answer was 'bring it to the dealer'. It would be nice to know in advance if there have been any updates at all to this car in the past five years. I know there is a very good possibility the dealer will blame my phone for this issue.
 

·
Premium Member
Joined
·
2,696 Posts
Hello, I have a 2013 Cruze LTZ with the full color touchscreen and navigation. Anyways I have an original iPhone 5 (not s or c) and there was an update done to it a few months back (10.3.3). Now every time I receive a phone call and answer it through my built in Bluetooth in the Cruze it will answer the phone and immediately transfer the call back to the phone itself. I have to manually transfer the call back to the Bluetooth every time.

I have had this phone and car for five years and it worked perfectly fine until this update. I tried another iPhone that had 10.3.3, and it had the same issue. When I tried my iPhone 3GS (really old), it worked fine. The real problem is that my phone will no longer have any updates since my phone does not support the current version 11. I read other forums and apparently this same issue was happening to BMW’s, but when they upgraded to iOS 11 (they had newer iPhone's) it resolved the issue (which I cannot do).

I have tried all the ‘normal’ steps. Unpair/ and repair the phone to the Bluetooth. Completely reset the phone. I even reset the radio on the Cruze, with no luck. I asked for advice on the Apple discussions about this and they said that the car probably needs a software update. They said that “vehicle manufactures are provided iOS updates to test their vehicles and they test to ensure their vehicles work with the latest Bluetooth profiles and iOS.”

So, this leads me here, are there any updates to the infotainment system of my Cruze? I have provided a picture of the list of updates that are currently on it. I wonder if this car has ever been updated since the factory. I have searched all over the internet and from what I read GM used to allow the customer to do updates through the USB, but now only the dealer can do it. Has anyone else had this issue with any phone?

Thanks in advance for your help.

View attachment 250073

Just an update, this it is definitely the car that is causing this issue. I tried the same phone in a 2013 Nissan Altima, and it worked fine. Also I tried chatting to GM online and their only answer was 'bring it to the dealer'. It would be nice to know in advance if there have been any updates at all to this car in the past five years. I know there is a very good possibility the dealer will blame my phone for this issue.
I don’t have any answers but I’m having iPhone issues too.

Up until a few months ago, the iPhone 6 worked flawlessly in my ‘14 CTD with USB cord connected. Never a glitch EVER.

Along comes iOS 11.0 (and all the subsequent “fixes”) and nothing but issues in the Cruze. Most of the time it’s the endless “INDEXING” message. Sometimes it will “lock” up the radio, no controls, no way to turn it off or switch sources. Often find it doesn’t charge when plugged in.

Tried everything. And yes, Apple will blame Chevy and Chevy will blame Apple so I’ve pretty much accepted it as part of life with Apple nowadays, not the company it used to be.

PS I am running a Scan Gauge 2 in the OBD port so I may try pulling the plug on that for awhile and see if anything changes.

The last thing I want to do is have the dealership flash the ECM. That might open a whole other can o’ worms.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #3 ·
After viewing many different threads on this I keep hitting dead ends in regards to this My Link update (if it even exists). Supposedly back in 2013 the plan was to have these updates available right on the Chevy webpage. There was a page that said 'coming soon'. Then all of a sudden one day this page disappeared.

The closest webpage that I found regarding updates was this; https://tis2web.service.gm.com/tis2web/ if you put your VIN number in it will tell about every software update for the car. However unless you are a mechanic (I am not), this site will probably not make any sense at all. I will call my dealer in the morning, I imagine I will have to bring the car in and they will charge me $100 just to tell me there are no updates.

It just seems odd to me that there is no information about successful software updates to MyLink anywhere out there on the internet. Even the Infotainment manual that came with my car has a 'software update' section that just tells me to go to the Chevy website. My best guess so far is that way back in 2012 when they came out with this system they were initially planning on doing frequent updates (a selling point for the car), however it never happened.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #4 ·
I found some more information regarding this. In this thread Merc6, posted a picture of that same 'Software Version Information' that I had. If you look at the picture there are six different updates. The last five are the exactly same as mine, however the top one is different. Mine is 22992942 version E0.0D.0D.0B (which is since this is hexadecimal 224.13.13.11). His has; 23420819 version E0.0D.0D.13 (224.13.13.19).

Its interesting to note from the picture I posted earlier all of my version numbers are the same E0.0D.0D.0B (at least the top six). All his are the same except for the very top one with. This leads me to believe that my car has never been updated since the factory. I think that very top number is how to tell if your car has been updated. So I am guessing there have been at least 8 updates since my car was new.

He mentioned that he got his last update in January. He said that the dealer did it.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #5 ·
I called the dealer this morning, and they basically had no clue about updates to MyLink. I called the GM 1-800 number and in short they told me there are no updates (and there never have been updates) to the MyLink in this car. It looks like my only option is to buy a new phone and that 'might' work. The thing that annoys me the most is that the phone works fine in a 2013 Nissan Altima (same year as mine).

Is there anyone out there on Cruzetalk that owns a 2013 Cruze with MyLink and Navigation that has an iPhone? If someone can confirm that they are not experiencing this 'transfer call' issue with iOS 11, it would greatly, greatly be appreciated. It would be extremely disappointing to buy a new phone and have this same issue.
 

·
Premium Member
Joined
·
2,696 Posts
I found some more information regarding this. In this thread Merc6, posted a picture of that same 'Software Version Information' that I had. If you look at the picture there are six different updates. The last five are the exactly same as mine, however the top one is different. Mine is 22992942 version E0.0D.0D.0B (which is since this is hexadecimal 224.13.13.11). His has; 23420819 version E0.0D.0D.13 (224.13.13.19).

Its interesting to note from the picture I posted earlier all of my version numbers are the same E0.0D.0D.0B (at least the top six). All his are the same except for the very top one with. This leads me to believe that my car has never been updated since the factory. I think that very top number is how to tell if your car has been updated. So I am guessing there have been at least 8 updates since my car was new.

He mentioned that he got his last update in January. He said that the dealer did it.
My ‘14 CTD Software Version Info shows 16 version changes. No clue what all this means or if it’s relevant to my iPhone issues. But my iPhone 6 worked fine with MyLink until iOS 11.0 came out.

Pics are Page 1, 2 & 3 (left to right)

91BD0601-B365-4AC5-AD0D-D75EA63BA327.jpg A2429E39-A791-4B39-88B5-15735D03F57A.jpg 4BE2D266-D7F6-45D8-A7AF-1D4FB413419C.jpg
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #7 · (Edited)
With your USB issue, I am not sure if this will help or not. My iPhone is 64GB and I used to have all of my songs on my iPhone (I have about 6000). Years ago I used to have that indexing issue, but when I had less songs on the iPhone the issue went away. I also had this same issue with an MP3 CD.

Maybe try to start with only 100 songs and see if it still gives you that indexing issue. I think MyLink cannot handle a lot of songs. If that does not work, maybe it will be fixed on a future iOS update. My main problem is that I am permanently stuck with iOS 10.3.3, there will never be a 10.4.

Also I 100% agree with what you said how Apple blames Chevy and Chevy Blames Apple. What this ultimately boils down to is Apple decided to change something in their software and it has created a compatibility issue with the MyLink system in the Cruze. This reminds me of when Windows Vista was released ten years ago, people had to upgrade many peripherals that they had been using for years. A lot of people downgraded back to XP. Problem is, Apple will not let people downgrade, and Chevy apparently has no upgrades. Both of our problems would be fixed if we could downgrade these iPhones.
 

·
Registered
Joined
·
223 Posts
I am having the same issue with my iPhone, except I am still running 10.3.3 on my 5S. Latest on the radio is 22965238 E0.0D.0C.B8 (Non nav MyLink) . I have had the same transfer call issue at least 6 months.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #9 ·
I bought a used iPhone 5s (since I guess very few people on here own both a 2013 Cruze and an iPhone). The phone had 10.1.1 on it and that OS version had the exact same issue. This leads me to believe this has been an issue since iOS 10 came out. I updated the phone to iOS 11.2.1 and I am still having the same issues.

So I guess in short, if you have a 2013 Cruze and an iPhone (which is apparently a rarity), do not update your phone past iOS 9 or you will have issues. Apple changed something on their end which causes compatibility issues with 2013 Cruze's. Also according to GM there never has been an update to MyLink and there never will be an update to fix this. So I guess the only fix is buy a new car? Or a 2013 Nissan Altima (since that works fine).
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #10 ·
I bought a brand new iPhone X that had 11.2.1 already installed on it. The Bluetooth worked 100% fine.


I was reading about this Bluetooth issue with iPhone 5's right from when they were released in 2012. I think it was solved at some point (at least by February of 2013 when I bought my Cruze) but iOS 10 seemed to bring this old problem back. This has to be a hardware/software issue with the Bluetooth in the 5, 5c and 5s. It will not work properly with some hands-free devices (at least with 2013 MyLink systems). So the good news is if you are reading this you do not have to buy a new car to fix this problem, only a new phone (assuming it bothers you enough).
 

·
Administrator, Resident Tater Salad
Joined
·
17,346 Posts
I bought a brand new iPhone X that had 11.2.1 already installed on it. The Bluetooth worked 100% fine.


I was reading about this Bluetooth issue with iPhone 5's right from when they were released in 2012. I think it was solved at some point (at least by February of 2013 when I bought my Cruze) but iOS 10 seemed to bring this old problem back. This has to be a hardware/software issue with the Bluetooth in the 5, 5c and 5s. It will not work properly with some hands-free devices (at least with 2013 MyLink systems). So the good news is if you are reading this you do not have to buy a new car to fix this problem, only a new phone (assuming it bothers you enough).
Versions of iOS 11 created all kinds of Bluetooth issues for a friend and I with 2 different cars/infotainment systems on iPhone 6's.

Apple just seems to constantly introduce software issues lately.
 

·
Registered
Joined
·
1 Posts
I have a 2015 Chevy Cruze AND an iPhone 6s Plus. The gps navigation used to work all the time through my Bluetooth. Now it only works through certain things like phone calls, if I’m playing through my phone. It definitely doesn’t work when you are on Sirius XM radio. I have an appt on Tuesday to see if my software needs upgrading. (You would think it would upgrade itself). It’s only going to cost $36. Regardless if it needs it or not but my radio has been freezing up too. The service center said it’s $92 to diagnose it if I want it diagnosed. Which I do not. I believe it’s the car’s software also. My phone keeps updating but not the car.
 
1 - 12 of 12 Posts
Top