Chevrolet Cruze Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
My car just dies. It is Like someone is turning the key off sometimes. I just got my car back today. It has had the trans rebuilt, new torque converter, new transmission valve body, spark plugs, oil change today. I never loss electrical power. I was going to change the fuel filter but I was reading some posts and it is in the tank so that's not an option! It has only done it while going slow since I have got it back. Once while i was going into valvoline and once when i got off the highway. Now that i think about it my steering wheel was turned to the left some both times but thats the only thing i can think of that is the same in both times. Has anyone had anything like this?!?! Anyone know what the fuel pressure is supposed to be idle? Also not sure if this helps with anyones answer but when i tried to use the automatic start, it cranked over for a longer time than normal.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
No, I never Loss electrical power. Everything is always on. Motor just dies. Always starts right back up.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Trans was rebuilt because 3 5 reverse went out. Then it started ding coming to stop because the torque converter was going bad and not disingaging. Trans came back out, new torque converter went in. Car now shifts great and have no lock up issue Like before.
 

·
Premium Member
2013 Cruze 1LT
Joined
·
984 Posts
Yes, was it dieing before? I am trying to narrow it down to if the trans rebuild caused this. Fuel pressure in the 50's for me.
 
1 - 6 of 6 Posts
Top