Chevrolet Cruze Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
435 Posts
Discussion Starter · #1 ·
Hey guys,

I went in today and got my oil pan leak repaired under warranty. When I left the dealer I noticed the check engine light was on, and when I got home I checked the codes.

I have these 6 codes...

imgur: the simple image sharer

Any idea as to what they are?


So far the only one I've found is the P0400 is exhaust Gas Recirculation Flow Malfunction.

What the heck is going on???


Thanks!
 

·
Premium Member
Joined
·
5,535 Posts
My first thought is they failed to reconnect several wiring harnesses that had to be disco'ed to make the repair.

I assume you gave it right back to them to finish the job.

Rob
 

·
Registered
Joined
·
435 Posts
Discussion Starter · #3 ·
Yeah I called them up and took it back in, it was the O2 sensor. Man... I've spent the last 3.5 hrs at the dealer. They gave me a free oil change and apologized. I just wonder what else they 'forgot'
 

·
Registered
Joined
·
1,166 Posts
Hey if you saw what GM payed the tech to do some of these jobs ! In some cases you will be lucky if there is any oil in it lol
 

·
Administrator
Joined
·
25,596 Posts
Mistakes happen. The fact that your dealership apologized and gave you a free oil change says a lot about their integrity. They sound like a keeper.
 

·
Premium Member
Joined
·
5,535 Posts
It pains me to admit these things happen.......The old, never enouph time to do it right but always time to re-do the job applies.

At least you got it resolved.

Rob
 
1 - 6 of 6 Posts
Top