Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2014 1.4 liter cruze. It has 46xxx miles. I have the same problem someone else here has had but a little different thats why im posting . my cruze started squealing lightly i thought oh must be a belt so i kept driving because it was after hours. About 20 minutes later my engine light came on the squealing got much much worse. And the car was trying to die on me i headed home asap. On the way i stopped removed the oil dipstick and it got a little better then when i entered it back in it was horrible still the whole way home. And as i pulled into the drive turned it off and opened the hood there was smoke flowing out of around the o2 sensor in the engine bay smelled like burning oil.. Any ideas?
 

·
Premium Member
Joined
·
8,003 Posts
I'd take a look at the PCV valve in the intake manifold, but that sounds pretty bad for that. It might be bad seals, or you may have excessive blow-by (bad news).
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks for your idea i have no idea what it is i just hope it is coveres by the warranty i have a appointment for it tomorrow and it will have to be towed there. Forgot to mention the oil was recently changed as well and is at 85 percent oil life now. But the oil is darker now than my girlfriends ford focuses oil that was changed 5 months ago with over 120 thousand on her engine
 

·
Premium Member
Joined
·
8,003 Posts
Everything I suggested should be covered. As far as I can tell, you're covered for everything IN the engine. Things ON the engine, not so much.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top