Chevrolet Cruze Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Loud squealing noise when using brakes I had brand new ones put on a few months after I bought the car. The noise continues to persist and I checked the rear brake discs!!
 

·
Administrator, Resident Tater Salad
Joined
·
17,301 Posts
At this point, the work will have to be checked. Could be cheap pads, or they didn't grease the back of the pads and the slide pins?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
At this point, the work will have to be checked. Could be cheap pads, or they didn't grease the back of the pads and the slide pins?
Not only that but stability track lights pop on radio turns on and off and after a few days of doing this car completely dies. Then the next day it is back to normal I don’t understand
 

·
Administrator, Resident Tater Salad
Joined
·
17,301 Posts
Not only that but stability track lights pop on radio turns on and off and after a few days of doing this car completely dies. Then the next day it is back to normal I don’t understand
Classic symptoms of a failed negative cable.

 

·
Premium Member
2013 Cruze LT
Joined
·
3,216 Posts
Loud squealing noise when using brakes I had brand new ones put on a few months after I bought the car. The noise continues to persist and I checked the rear brake discs!!
Is it only when you brake?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Classic symptoms of a failed negative cable.

My mechanic cut the wrap around the cord to see if they needed replacing he found nothing. The car has done this since a bought it in November of 2020
 

·
Premium Member
2013 Cruze LT
Joined
·
3,216 Posts
My mechanic cut the wrap around the cord to see if they needed replacing he found nothing. The car has done this since a bought it in November of 2020
You can't see the inside of a cable crimp to see if it's defective.
 
  • Like
Reactions: jblackburn
1 - 10 of 10 Posts
Top