Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
2012 Cruze lt2 with about 58k. Not sure why but I'm having more issues with my coolant level. I keep adding but seems as if it's just evaporating or getting into the core and also emitting an odor. It's faint but I can smell it. I know this was an issue in regards to coolant and the Cruze before because I read about it. Seems to be an issue and was wondering if it's really a factory defect, will gm cover it?


Sent from my iPhone using Tapatalk
 

·
Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
12,374 Posts
2012 Cruze lt2 with about 58k. Not sure why but I'm having more issues with my coolant level. I keep adding but seems as if it's just evaporating or getting into the core and also emitting an odor. It's faint but I can smell it. I know this was an issue in regards to coolant and the Cruze before because I read about it. Seems to be an issue and was wondering if it's really a factory defect, will gm cover it?


Sent from my iPhone using Tapatalk
Have you read through any of this yet?

Antifreeze Smell Thread

Also this from Dr. Ober <GRIN>

Water pump or coolant tank cap. This is a sign of one of these two leaking under pressure. Get a bottle of coolant dye and dump it in your coolant. Then you'll be able to find the leak with a flashlight.
 

·
Premium Member
Joined
·
25,596 Posts
As ChevyGuy added it could also be a pressure leak at the spider coupler on the coolant tank side of the engine block.
 

·
Registered
Joined
·
45 Posts
on my MY2014 1.6L T the coolant was leaking from the reservoir hose connection. The entire reservoir was replaced under warranty as it is a common fault.
The image on the left is the new one, you can see the brass inside the connection is the obvious diffrerence.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top