Chevrolet Cruze Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,

I have a 2010 Holden Cruze 2.0 Diesel(Korean Built). The car is manual (5 speed). All was well till the other day, i went to shift up to 3rd and it grinded. I tried double clutching it and still grinds.

That's the first issue.

Secondly, last night I made a right hand turn at low speed(20kph - 10mph) and hit a traffic island. The car continued for another 10kms. Then all power to the wheels was lost suddenly.The car coasted to a stop while i went through all gears to see if any of the gears worked, nothing.

i can start the car and put it into any gear (yes 3rd still grinds), release the clutch and the car sounds like it's trying to move but nothing.

Strange part, i jacked the front end of the car up and put it in gear and released the clutch and the wheels spin. the speedo and everything work as though the car is in motion..........

what could the issue be? PLEASE HELP
 

·
Banned
Joined
·
10,296 Posts
All they symptoms of a worn out clutch. Been driving manuals for some odd 63 years now, use to be a six buck two hour job.

Use to be fun to floor the gas, ease out the clutch, called riding it for maximum take off, but not anymore, around 500 bucks for parts and a weekend to replace it. So very careful when taking off in first gear, when it second, can hit the gas a little bit when the clutch is fully engaged.

Can no longer do this job by myself, need at least two other guys to help me. Clutch was still good in our now old 04 Cavalier with 150K miles on it, but the rest of the body was a pile of rust. Probably not a problem where you live.
 
1 - 2 of 2 Posts
Top