Chevrolet Cruze Forums banner
1 - 11 of 11 Posts

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #1 ·
Well as I am sure everyone knows I have had countless issues with my Cruze from blown turbos, PCV valves, piston ring failure, all type of issues I experienced. My latest issue was due to a brake & rough idle issue. Well after researching this forum, I decided to pump the e-brake thinking yeah this isn't going to fix anything, well that actually did fix it, it no longer sticks & runs awesome now, I don't feel any further drag that I felt the transmission seems to shift like butter now all six gears as I was having a slight jerk in the up-shift to third. The rough idle issue, I resolved by simply bumping my gas from 87 to 89 & after two tanks I seen a huge difference in the response & mileage I went from like I think 289mi per tank on regular to like 450mi no 89, I know there is way better in these forums, but I find that a huge jump just simply changing my octane.

Most would be wondering 289mi on a tank of regular, well I have alot of up & down hills I travel & curvy & plus my foot doesn't help :)

So overall I just wanted to say that my car now runs awesome; no oil leaks, nothing that is noticeable & I finally am enjoying my Cruze now. I am getting close to 10K miles on my Cruze since engine swap & everything is good thus far.

Now lets hope since the writing of this thread I don't have to visit the dealership! Lol
 

·
Super Moderator
Joined
·
7,804 Posts
What's your current odometer mileage?

(BTW my best tank was 752 miles.)
 

·
Super Moderator
Joined
·
7,804 Posts

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #5 ·
My goal is to reach 125K then my warranty will be gone & then its trade in time :) Mainly want to see if I can actually reach that mileage w/o any further repairs or issues, so fingers crossed & we shall see. Then I am going after a Gen2 Cruze LT w/ same specs my current Cruze has.
 

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #9 ·
Well since this thread was updated I actually forgot about doing a follow-up on this w/ my results. That being said, I have not had any further issues or 'leaks' that I could notice its dry & clean under there as many times I have washed under there. Lol

So all seems to be good & I am concluding that I ran over something nasty & got that stuff on the control arm. So if anything else arise from this I'll update this thread w/ any information to help w/ anyone else that may experience such.
 

·
Patience Of Job
Joined
·
562 Posts
Discussion Starter · #11 ·
What do you mean by "Pumping the e-brake" sorry if it is dumb question.
Its just a term I used, it just simply means I pulled up on the e-brake & down & up for a few turns. That took care of my issue w/ the brake 'sticking' so to this day I haven't had any further issues w/ it.
 
1 - 11 of 11 Posts
Top