Chevrolet Cruze Forums banner
1 - 20 of 24 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter · #1 ·
So Today, I started my car up and hit the Nav destination button and nothing/loading map data message..Then after driving a few miles, click Radio Display shuts off, then powers back on...Clock different time, cannot set time.. nave still wont work, then display off again..Back on, now Nav working, but cannot enter a destination, missing characters, ect.. Also when xm on, no info on whats playing, all wacky..

Ive had the Nav display shut off some years ago like a few time, but it always worked ok when back on..

Yes, ive had the positive and negative cable changed many time before, yes ive had the Nav updated with new flash updates before, yes the battery is new, only 5 months old, Yes I checked the cables to the battery and to the chassie all is tight and not loose, yes my battery goes dead when car sits for a week,,'

I think my cars Nav/radio display has some sort of short in it causing my battery to die in a week and is why my display is all wacky,,,

Its really weird as the display will be missing letters when you want to enter even the first letter... Now several hour later, just a blank screen when hitting the Nav button, radio seems to work... 2012 LTZ with Nav/xm...

Ive read through all the post and I cant find anybody with these same issues...All the others were fixed fixed by the normal negative cable replacement that already been done,,
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #2 ·
Well 50 views and I Guess I stumped everybody...Today Nav Started to work for a little while,, Now I noticed that the radio comes on all by itself sometimes after the car is off for 10 minutes or so,,Weird! I know becase I have the windows down and I work in my garage...
 

·
Premium Member
Joined
·
8,003 Posts
I'm not sure what to suggest to look at other than power in general. The MyLink I've looked inside have 5V and 3.3V regulators and I found the capacitors weren't as healthy as I'd like. So at some point we may see power problems with the radio itself. Much like a power supply going south on a desktop.

I have no idea if that's the problem with your unit or not.
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #4 ·
Well woke up to day nice and early to go to the dealership to have this mess fixed, and surprise surprise, everything is working perfect...three days of **** fixed on its own, guess I git to bring it in, in the act somehow..
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #5 ·
Ok So today Nav not working again, went straight to dealer and guess what happened! This NEVER happens at the dealer...! The Service writer gets in the car, and the whole Navigation/HVAC/Radio Display Turn Off, Then on, then off again, then On , Then a minute later off again, wont come back on for 5 minites, and off course no Nav when it did turn on! Amazing, this never happens when your at the dealer, they usually just look at you and don't believe you!

Let you guys know what happens Tomorrow...
 

·
Super Moderator
Joined
·
7,815 Posts
I was going to tell you to bring your car to a catholic priest and pass him a $50 for the parish poor fund.

But seeing how you got it to the dealer, maybe tell them to do that.
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #8 ·
Well Boys the verdict is in, they say the radio is bad, Radio Part Number: 22879332
Retails for over $1424 They want to sell it to me for $1135 plus Tax Plus $300 for installation..So $1537.....ouch

Only good thing is if this doesn't solve the issue, they got to eat it...What you guys think?
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #9 ·
I actually have a wholesale account with another Gm Dealer near my house, I went to get a price and it was only Slightly Higher by like $20 for me to buy it, but no Tax...But the problem is I think it all has to be programmed....and Hopefully it will come with an updated map....

Also, I heard you there is actually a core fee, so you cant keep the old unit....
 

·
Premium Member
Joined
·
461 Posts
Well Boys the verdict is in, they say the radio is bad, Radio Part Number: 22879332
Retails for over $1424 They want to sell it to me for $1135 plus Tax Plus $300 for installation..So $1537.....ouch

Only good thing is if this doesn't solve the issue, they got to eat it...What you guys think?
OUCH is right!

Sent from my SAMSUNG-SM-G870A using Tapatalk
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #11 ·
Its like what can you do, The whole car wired through this central Nervous system, HVAC, Amplifier, NAV, All the options for the Car, I don't think there is anyway for an aftermarket system to Work correctly with all this BS, not to mention, the lowerering down of Air Con/heater when a call comes through,ect.. It would cost probably more for an aftermarket system, if you could even get it to display all the HVAC info, outside temp, ect.. Hopefully it will come with an Updated 2017 s/d card. it would be worth $200 I guess...
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #12 ·
A Cruzetalk member sent me info that you could get the Radio Fixed for $500, wich is a good deal, but with all the electrical issues this car has, I think I'm just going bite the bullet just so I can stick it to the dealer in case it still has issues....
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #13 ·
A Cruzetalk member sent me info that you could get the Radio Fixed for $425, wich is a good deal, but with all the electrical issues this car has, I think I'm just going bite the bullet just so I can stick it to the dealer in case it still has issues....
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #16 ·
Same HU.

I think I'd try to find one from a junkyard over either option.

Have you seen the MyLink upgrade thread around here?

Is it plug and Play? Doesn't it have to be programed at the dealer still?

Ive been looking though the Forums, haven't found anything that would deal with an aftermarket Double Din Nav that would be able to show the HVAC contols on screen , ect..
 

·
Administrator, Resident Tater Salad
Joined
·
17,546 Posts

·
Registered
Joined
·
37 Posts
Sorry to resurrect this old thread, but my radio has just been giving me weird problems similar to you described. The other day, all my favorites were gone, the time was not displaying and I couldn't even change the time myself. The only thing displaying was the RDS data from the radio station. Even the exterior temperature display was out.

This morning, everything was semi back to normal, but when I went into the config screen, it was blank. Something is def. wrong with the radio. It still plays music, and the heated seats/HVAC work on the bottom of the display.

Was the radio determined to be the problem? What was your course of action? Thanks.
 

·
Registered
Joined
·
4 Posts
Nav/Radio

I have a 2015 LT RS. This winter I have had a problem where my FM stations won’t come in if it’s too cold outside. My satellite radio stations come in just fine. Once the car warms up the FM goes back to normal.
 

·
Registered
Joined
·
4 Posts
Not sure if all the pioneer systems all have the head unit: 22879332, but mine has the pioneer badge on the front door speakers, and the head unit is the same. I know this because I recently had an idiot attack, left all windows (including the moon roof) open. Heavy rain soaked the inside. I have them down to the board level and see no signs of water damage except on the button control panel. I'm thinking of getting a new panel which is like $70 from what i've seen.

I know this is an old topic but if the panel doesn't fix mine, is anyone still fixing the radio, or could perhaps tell me how to fix? I'm decent with electronics. My job is working on cell phones and I'm learning microsoldering from the pros i work with.

Thanks for any help.
 
1 - 20 of 24 Posts
Top