Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello everyone!

I purchased a 2011 Chevy Cruze Eco a couple weeks ago and loving it so far. Did a lot of research before purchasing the car to really know that this is the car that fits me best. It's economical, it looks sporty, equipped with a turbo, and not a **** Honda :) Mechanically everything is good, and I even took it to an O'Reilly's during the test drive to get the system scanned with the OBD and no codes, not even P1000 which is evidence for codes being erased and in calibration phase.

Aside from the engine turning over abruptly during warm starts, no major issues to speak of. However, I just noticed on my commute home that the battery voltage weirdly fluctuates from 12.0V to 14.0V with no evident correlation to pedal input, engine revolutions, idle, etc. It seems to be acting on a mind of its own.

During the pre-purchase inspection, I did identify and mention corrosion on the battery terminals, and maybe that's causing a large range of battery voltage? Could anyone give input if they've experienced this before? I know I have to clean off the corrosion soon to better diagnose this issue, but if you have any pointers, I would appreciate it.

Thanks!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thanks so much, everyone! Very good insight on this, and I won't have to worry too much. I will be sure to inspect and clean any corrosion spots on the battery terminals. Thanks again everyone.
 
1 - 2 of 2 Posts
Top