Chevrolet Cruze Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Ok so I was just doing some cleaning and figured I'd take the tb off and clean it since I recently had a pcv issue well I decided to just take the whole tb off and give it a good cleaning well I honestly don't know what I've done wrong but nothing in my memory stands out but anyways I put it back together and started her up to find a engine reduced power mode starring me in the face and to the best of my capabilities I've tried the relearn procedures I mean I've even tried procedures of other car company's and nothing works I mean I've gotten it to where it's not completely crippled and can at least limp down the road but I can't figure someone please help thanks in advance
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
196 Posts
Did you move the throttle plate manually when you were cleaning it? If so you may have damaged it.
 

·
Premium Member
2013 Cruze LT
Joined
·
1,425 Posts
Did you move the throttle plate manually when you were cleaning it? If so you may have damaged it.
I did that recently. Whoops. No issues as of yet.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I did move it manually and I'm pretty sure I did damage it or at least by now it is because I seen a video showing a guy with what looked like a similar gm throttle body and he was rebuilding the uncased tps sensor show I figured might as well give it a shot cause it ain't working anyway we'll just my kinda the guys throttle body on the videos simply came apart when he popped off the clips on the case we'll like I said my luck I have a throttle body that has the same exact clips on it as if the ** thing even comes apart I got the clips off and it's as if the clips are for looks cause for me to pull it apart oh it's definitely gonna have to be broke apart so let's recap this months fun with the ol chevy cruze first off had to replace both front axles both front rotors brakes were good but the old rotors were warped so those brakes got tossed for new ones then total pcv failure I mean I was coasting down the road and what used to be my favorite car just start hiccuping and coughs out black sludge and smoke everywhere we'll just so happen to be at a bad time so I didn't have the money for a fix kit so I kinda made my own I already had some heater hose and epoxy so I just bought some fittings and a cheap break booster check valve and let me tell ya that took some patients but got it done and now this throttle body issue I mean hey I understand gm can't sell reliable cars that don't break down cause people need jobs but ** I feel unsafe farting in this frail fragile car it's almost scary thinking about even fixing the throttle body issue cause let's face it its a good chance the wheels might roll off the thing in park considering all the other really really dumb issues with this car I think I'm gonna do me the car and anybody whose ever in the car with me when it breaks down a favor and not only junk it but actually take it to the crusher and he'll with getting money I'll give money to crush this joke of a car
 

·
Registered
Joined
·
84 Posts
To me...sounds like a BIG case of tinkeritis.. Why were you "cleaning? All that smoke, etc. was most likely a PCV problem that should be fixed FREE under the GM 100,000 miles drivetrain warranty. Warped rotors? Enough "warp" that the brake pedal pulsated? What year is your CRUZE? Milage? Buy it new...or used?
Sounds like you broke something...and are now blaming the car.
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
196 Posts
I'd just save all the hassle, replace the throttle body assembly, and chuck the situation into the "things not to do again" bin. Don't blame GM because you took the throttle body off, tried to clean it, and broke it. Live and learn :)
 
  • Like
Reactions: bEngland

·
Premium Member
2013 Cruze LT
Joined
·
1,425 Posts
I have an extra used TB if you're interested. Assuming you have a 1.4L.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
I was cleaning it cause it's been cold in the mornings and the car has been hard to start the car has 180,000 I will admit I do tinker but everything I've seen so far about cleaning the tb seemed pretty straight forward so I figured I could do it now my question is is there anyway you can simply replace the tps sensor and not the whole tb?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
Oh and for anybody who thinks that hey the tps has clips on it maybe I can just clean it up well that's a confirmed nope the clips are there for weight distribution and aerodynamics I guess I don't why else that would be there cause tps sensor is soldered in
 

·
Registered
Joined
·
84 Posts
180,000 miles ? A true accomplishment. Gives me a bit more confidence that my CRUZE will last a long long time.
 

·
Premium Member
2013 Cruze LT
Joined
·
1,425 Posts
Is there anything wrong with it and when you swapped yours out was there a relearn procedure
Not that im aware of, was ordered off ebay to fix a rough idle and surging. No relearn, I just disconnected battery when I did the install. Little did I know it was the aftermarket throttle body spacer causing the issues and my throttle body was fine. I did test with this one and it seemed to run just fine as well. It's up to you, no obligation :)

289180


289181


289182
 

·
Registered
Joined
·
28 Posts
Discussion Starter #15
Hell yeah I want it but I'm bout to head into work now how do you wanna go about payment but like it won't be til I get off work that I can send it and Im in Knoxville TN just to so you can figure out the shipping
 

·
Premium Member
2013 Cruze LT
Joined
·
1,425 Posts
Hell yeah I want it but I'm bout to head into work now how do you wanna go about payment but like it won't be til I get off work that I can send it and Im in Knoxville TN just to so you can figure out the shipping
I will PM you.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #17
Can anybody help me I just bought a new tb from AutoZone disconnected battery put new one on connected battery turns over but won't start it's started before with the old one just had no gas pedal now with the new one the gas pedal and tps isn't in correlation with each other I don't have a volt meter but I've bout everything I could think please some input
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
196 Posts
Autozone had an OE throttle body?
 
  • Like
Reactions: Thebigzeus

·
Registered
Joined
·
28 Posts
Discussion Starter #19
It's a bosch throttle body but idk if it's good or bad I've put it in put the old one back in but still won't start I've got the codes down to just 1 and 2135 idk I'm bout ready call it on this one I can't keep throwing money at this piece of 💩
 
1 - 19 of 19 Posts
Top