Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
New member here!
Today I was driving home, and suddenly my music turned off, and so did my display touch screen. It turned back on after about 30 seconds, then 2 minutes later turned off again, again turned back on. 4 minutes later it once again turned off, and sadly hasn't turned back on since. The volume, media, radio etc buttons that arent on the touch screen are lit up (but dont work). I changed the fuse, and now loud static cuts in and out, I can turn it down on the steering wheel but that's it. I cant chsnge stations, it wont connect to my phone, and the screen is black.. I'm going crazy trying to figure this out. Someone please help lol.
 

·
Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
12,680 Posts
New member here!
Today I was driving home, and suddenly my music turned off, and so did my display touch screen. It turned back on after about 30 seconds, then 2 minutes later turned off again, again turned back on. 4 minutes later it once again turned off, and sadly hasn't turned back on since. The volume, media, radio etc buttons that arent on the touch screen are lit up (but dont work). I changed the fuse, and now loud static cuts in and out, I can turn it down on the steering wheel but that's it. I cant chsnge stations, it wont connect to my phone, and the screen is black.. I'm going crazy trying to figure this out. Someone please help lol.
Welcome Aboard!(y)

It could be loose wiring, especially the ground. Have you been in the dash at all?


I just tried to answer a similar question here:

Don't forget to introduce yourself and your Cruze here.
 
1 - 2 of 2 Posts
Top