Chevrolet Cruze Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi, I have a 2012 Chevy Cruze Eco with about 94k miles on it. Recently the engine light came on while I was driving it and this morning the engine fan has not stopped running and it states it?s running on cold. A memo came on stating A/C was turned off due to high engine temp but it?s been running on C and my A/C wasn?t even on.. Help please!
 

·
Premium Member
Joined
·
5,638 Posts
Welcome to you! Sorry about the problem, might have the Negative Battery cable looked at by a Dealer. The replacement might still be covered for free
 

·
Premium Member
Joined
·
2,697 Posts
  • Like
Reactions: Eddy Cruze

·
Premium Member
Joined
·
5,535 Posts
I think you should check the coolant level before you go anywhere else to verify it is a false warning.......add if required and THEN take it in.

Rob
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
I took it to Autozone to check and the guy told me I needed to replace my thermostat. So I?m taking it to the mechanic
 

·
Registered
Joined
·
120 Posts
Welcome.

I had the opposite problem on a Cobalt. My thermostat was stuck open. The engine would take a long time to get warm and would cool down if I coast down a long hill.

I believe if you turn on the heat and roll down the windows, then it will take the heat away from the engine until the thermostat is replaced.
 

·
Moderator
Joined
·
10,712 Posts
Welcome to the forum. Once you get the other issue taken care of, still have them check the negative cable to see if it was swapped out yet.
 
1 - 12 of 12 Posts
Top