Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey everyone! I know that this has probably been brought up a lot on this forum, but I am new to this site and still trying to learn how to navigate. I have a 2011 Chevy Cruze 2LT that was purchased brand new. I have been a long time chevy owner, but this is the first time I have branched into their small cars. Since purchasing the vehicle I have had issues - I had to have the entire transmission replaced within a year of purchase.

Today I noticed the heater was not properly working in my car and checked my coolant levels in the car and it was very low. It did not cause my engine to run hot but I noticed the fan was on like overdrive and making a very loud noise. There are no noticeable leaks in hoses or mysterious puddles or stains. The oil in the engine does not have a whitish tinge to it either. What do I need to do? I haven't noticed any strong antifreeze smells in the car like others have - but I have noticed a very slight smell in the past two weeks (not consistent). My dealership is 45 minutes away... what have others done in this instance?

Thanks guys!
 

·
Administrator
Joined
·
25,596 Posts
This sounds like a leaking water pump.
 

·
Chevrolet Customer Assistance Representative
Joined
·
5,722 Posts
Welcome to the forum cboy! I'm really sorry that you have had issues with your Cruze. Could you send me your VIN and full name so that I can look into this. I look forward to hearing from you.

Jackie
Chevrolet Customer Care
 

·
Premium Member
Joined
·
5,535 Posts
Refill the system and have additional coolant on board for the 45 mile ride......this will not repair itself.

Rob
 

·
Premium Member
Joined
·
1,673 Posts
Refill and add a leak trace to it. Sounds like your water pump though. Several people never noticed the leak, as the it can drip on hidden areas and often times come out like steam...
 
1 - 5 of 5 Posts
Top