Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Howdy all!
I've been reading and lurking for a while since I got my Cruze last year but had something interesting, or maybe at least entertaining to share so signed up so I can post about it.

My car is a 2012 Cruze ECO I bought used last year. It had 78k miles and was my bright idea to be a reasonable commuter.
It does get awesome gas mileage, but has proven to be a mixed bag car wise and the most troublesome car I've had in years...

More to follow in my 1st post after this one.

Thanks!
 

·
Super Moderator
Joined
·
4,954 Posts
Welcome and I and a few others have a 2012 Eco. What color is it and manual or automatic? Where are you from? Tell us a little more about your car and what kind of problems are you experiencing. I am sure we can try to help with whatever is going on with yours.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Hi and thanks for the welcome.
My car is a 2012 Cruze ECO, 6pd manual. Bought it used with 78k miles on it last fall and up to 85k now.
My current issues with the car seemed appropriate for the 1.4 powertrain section so I posted over there. :)

Past issues, had the P0171 as a starting point that led to 4 dealer trips over 2 months before they'd sorted it all out. 1st visit they fixed and cleared the code, but then had chronic oil leak that took 3 more visits and 2 additional repairs to get all sorted. Once all done, valve cover was replaced twice, and the airflow valve to be completed fixed with the code gone and no more burning oil smell.
 

·
Administrator
Joined
·
25,096 Posts
And now you know why the car was traded in. Let's see, P0171 is almost always a known PCV valve failure. The oil leak may or may not have been related - I can't tell. The underboost code you reported is also a known failure point but not a common one.
 
1 - 4 of 4 Posts
Top