Chevrolet Cruze Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi, I just brought the 2015 Chev Cruze a month ago. I took it on a trip (about a 4-5 hour there and 4-5 hours back) when i started my trip back i notice the service engine light was on. I was told from a friend not to worry, that it could need an oil change or something like that. While driving back it start to putt putt. About a day after getting back it shakes when stopped at a red light, more like the car giggling me back and forth. Also, It sounds like it would go idle and cut off if in park, but it never does. I've also notice a little noise coming from the left front side of the car. its a squeaking noise. Maybe from the tires? I'm not sure. This all happen during to one day after my trip. But i checked under the hood today and noticed that there was a tiny bit of coolant. could that be why those problems are happening? Also, my dad drove it and said there's no 'get up' it takes awhile for the car to go fast. He said to take it back to the dealer and get another car. I'm just really scared that i messed my car up taking it on a trip and driving it for 4-5 hours with the service light on. If i need to take this car back, can I? Its been 30 days since I brought it. I like my car I honestly don't want to take it back, if it came to it, but i also just got the car, nothing should be wrong and I should be able to take it on multiple trips! right? What could be wrong? I really want to keep my car!!
 

·
Premium Member
Joined
·
5,193 Posts
Hi Angel, most Dealers don't take Cars back after 30 days, there are plenty of places that will now take a Car back within 10 days or so, and this was unheard of not long ago. Driving a car with no coolant can mean the death of an engine. A friend of mine had a Chevy Vega, made in the same plant as the CRUZE. His engine would just conk out and stall, all he needed to do was add Oil and off he would go with no damage An overheated car is different, you shouldn't have driven the Car with the light on.
Welcome!

Post a Pic when you can
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Thanks for replying. My dad checked the coolant and said to add a little more and it should be fine. I don't believe the car was running hot. There was nothing to indicate that it was. No alarm going off or warning about it. Just the service engine light. I'm going to get it looked at tomorrow. Will post what happens after that. Hopefully its 100% free since i just got the car. Guess ill see what the extra $4,000 for the warranty is really worth!
 

·
Registered
Joined
·
222 Posts
Thanks for replying. My dad checked the coolant and said to add a little more and it should be fine. I don't believe the car was running hot. There was nothing to indicate that it was. No alarm going off or warning about it. Just the service engine light. I'm going to get it looked at tomorrow. Will post what happens after that. Hopefully its 100% free since i just got the car. Guess ill see what the extra $4,000 for the warranty is really worth!
4k for the warranty =O

Sent from my SM-G955U using Tapatalk
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,462 Posts
... on a trip (about a 4-5 hour there and 4-5 hours back) when i started my trip back i notice the service engine light was on. ....
While driving back it start to putt putt. About a day after getting back it shakes when stopped , more like the car [j]iggling me back and forth. ...
sounds like it would go idle and cut off if in park, but it never does. I've also notice ... noise coming from the left front side of the car.
its a squeaking noise. .... ...i checked under the hood today and noticed that there was a tiny bit of coolant. ...
...there's no 'get up' it takes awhile for the car to go fast. ... i ... tak[e] it on a trip for 4-5 hours with the service light on. ....
Welcome Aboard!(y)

As for the coolant leak, clean up all the wet areas and run the car for a bit and look around pretty well for the location of the leak. Based on that we can recommend what to probably replace. I say replace as these vehicles use a lot of plastic. The main culprit is the water outlet, but without knowing where, it might be something else.
Post picture of the leak area.

As for the code and related issues, go to Autozone or another big box auto store and have them read the codes and post them here.

In the meantime have your mechanic read this:

2011-2016 Cruze 1.4 PCV Valve Cover/Intake Manifold Issues

Don't forget to introduce yourself and your Cruze here.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
I forgot! I filled my fuel tank up way too much to the point where some gas came out. I think that's why i have the check engine light on and my car has been running the way it has. I put gas in it around an hour into the trip and overfilled the gas tank and then about 4 hours later is when the check engine light came on. I'm still taking it in today and will post later.
 

·
Registered
Holden Cruze 1.8L 2012. 63k miles odometer (15-03-2020).
Joined
·
80 Posts
The Check Engine light produces error codes. I understand Autozone and maybe other stores in the U.S. will plug in a ODB2 scan tool and read them for free. I got a cheap Bluetooth ODB2 reader that connects to my Android phone and the free Torque lite app reads them out.

You're cars computer will not issue a check engine light unless it is serious. Pull out them codes and give them to us.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
I don't understand what codes are. Nothing shows up except my check engine light is on, and the remote start isnt working anymore. I had to reschedule my appoint (no service people
) and will take it tomorrow. I'm not going to drive it till then.
 

·
Registered
Joined
·
222 Posts
I don't understand what codes are. Nothing shows up except my check engine light is on, and the remote start isnt working anymore. I had to reschedule my appoint (no service people
) and will take it tomorrow. I'm not going to drive it till then.
The check engine light means something is wrong. You need to hook a obd2 reader into the port above your brake pedal and scan. It will give you a code number telling you why the engine light is on and than you can fix it.

Any auto parts store.. o Reilly, advance auto, napa...etc will scan your car for free and tell you the code.

The check engine light won't come for maintenance. It only illuminates when there is a problem and needs to be fixed for the engine to run properly.

Obd stands for on-board diagnostics. It's how you can access and communicate with the cars computer. Every modern vehicle has this connection port.



Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #12
I went to autoZone and scanned it. The repair shop keeps rescheduling my appointment (now Wednesday) but the code is P0171 then it goes on to say replace fuel injectors. There’s another code that AutoZone said is because of the P0171 code.

All codes are:
P0171 System Too Lean (Bank 1)
P015B O2 Sensor Delayed Response- Lean to Rich Bank 1 Sensor 1
 

·
Registered
Joined
·
222 Posts
I went to autoZone and scanned it. The repair shop keeps rescheduling my appointment (now Wednesday) but the code is P0171 then it goes on to say replace fuel injectors. There’s another code that AutoZone said is because of the P0171 code.

All codes are:
P0171 System Too Lean (Bank 1)
P015B O2 Sensor Delayed Response- Lean to Rich Bank 1 Sensor 1
Don't replace your fuel injectors. More than likely is the evap purge valve or solenoid from overfilling your tank. How did you overfill it?

Sent from my SM-G955U using Tapatalk
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,462 Posts
I see now lol
Yes I did
You did what? What did you see? It is better to answer using the reply link at the bottom left of each post. The answer will be attached to the question.

Potential causes for this code, P015B, to set are:

Defective O2 sensor(s)
Burnt, broken, or disconnected wiring and/or connectors
Defective catalytic converter
Engine exhaust leaks
Read more at: P015B O2 Sensor Delayed Response - Lean to Rich (Bank 1 Sensor 1)

A code P0171 may mean that one or more of the following has happened:

The MAF (Mass Air Flow) Sensor is dirty or faulty Note: The use of "oiled" air filters may cause the MAF to become dirty if the filter is over-oiled.
There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
There could be a vacuum leak downstream of the MAF sensor
Possible cracked vacuum or PCV line/connection
Faulty or stuck open PCV valve
Failed or faulty oxygen sensor (bank 1, sensor 1)
Sticking/plugged or failed fuel injector
Low fuel pressure (possible plugged/dirty fuel filter!)
Exhaust leak between engine and first oxygen sensor
Read more at: OBD-II DTC: P0171 System Too Lean (Bank 1)


And just because -

2011-2016 Cruze 1.4 PCV Valve Cover/Intake Manifold Issues
 

·
Registered
Joined
·
12 Posts
Discussion Starter #16
You did what? What did you see? It is better to answer using the reply link at the bottom left of each post. The answer will be attached to the question.

Potential causes for this code, P015B, to set are:

Defective O2 sensor(s)
Burnt, broken, or disconnected wiring and/or connectors
Defective catalytic converter
Engine exhaust leaks
Read more at: P015B O2 Sensor Delayed Response - Lean to Rich (Bank 1 Sensor 1)

A code P0171 may mean that one or more of the following has happened:

The MAF (Mass Air Flow) Sensor is dirty or faulty Note: The use of "oiled" air filters may cause the MAF to become dirty if the filter is over-oiled.
There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
There could be a vacuum leak downstream of the MAF sensor
Possible cracked vacuum or PCV line/connection
Faulty or stuck open PCV valve
Failed or faulty oxygen sensor (bank 1, sensor 1)
Sticking/plugged or failed fuel injector
Low fuel pressure (possible plugged/dirty fuel filter!)
Exhaust leak between engine and first oxygen sensor
Read more at: OBD-II DTC: P0171 System Too Lean (Bank 1)


And just because -

2011-2016 Cruze 1.4 PCV Valve Cover/Intake Manifold Issues
Thanks for the advice, I’m new here lol. But my reply for “I see now” was in response to what codes are. And “Yes I did” was about putting too much fuel it the car.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #17
I took it to an out of network repair shop. I’m trying to get it fixed for free before my 30-day ‘fix anything wrong with it’ part of the warranty expires on the 26 in two days. But I’m waiting for them to look at it. I will keep everyone posted. The mechanic said I can’t overfill a gas tank, but I think it can.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #18
Ok so the repair shop could have fixed it for $354, but the warranty people and they told them not to work on it and that I’m forced to take it to a Chevrolet dealer. So now I have to wait till tomorrow. But the repair shop gave me these codes if anyone is interested.
P0131
P015B
P0171
P0507

the repair man said it’s basically the valve cover.
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,462 Posts
Ok so the repair shop could have fixed it for $354, but the warranty people and they told them not to work on it and that I’m forced to take it to a Chevrolet dealer. So now I have to wait till tomorrow. But the repair shop gave me these codes if anyone is interested.
P0131
P015B
P0171
P0507

the repair man said it’s basically the valve cover.
Open the hood, pull the cosmetic cover off of the engine and put your finger over the opening in the round disk looking area on the valve cover while the engine is running. If you can feel air blowing out, the vacuum regulator is ruptured. This is normally a symptom of the intake PCV valve not working allowing the engine to be pressurized, blowing the valve cover vacuum regulator (which is not repairable and will need to be replaced), eventually causing oil leaks on the valve cover, CPASV seal and sometimes the crank seal (which sounds like a chirping noise.) Read the post in number 15 above and follow the links to the fix kit. I recommend V3 for you at the moment.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #20
Now the car won’t cut off. It says no remote detected, the engine cuts off but the dashboard lights won’t cut off. I don’t know what to do. Chevy doesn’t know either. The remote locks the doors with no problems but it won’t decay the remote to cut off!!
 
1 - 20 of 29 Posts
Top