Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello I'm new here and I recently bought a 2012 Chevy Cruze 1.4 Lt turbo. Well it was running then shut off while idling and wont turn back on. I've replaced the battery, spark plugs, coil pack still nothing. Lights radio etc all work. Had a compression test done and the guy said 30lbs of pressure and that I need to buy a whole new motor. And another issue is someone says I have antifreeze in my oil but when I looked at oil it didnt look like there was antifreeze in it, it just looked black. Need help asap
 

·
Registered
Joined
·
1,010 Posts
If there is only 30 psi compression you definitely have a problem. Is that on all cylinders or just one? Could be a blown head gasket?
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
7,495 Posts
Hello I'm new here and I recently bought a 2012 Chevy Cruze 1.4 Lt turbo. Well it was running then shut off while idling and wont turn back on. I've replaced the battery, spark plugs, coil pack still nothing. Lights radio etc all work. Had a compression test done and the guy said 30lbs of pressure and that I need to buy a whole new motor. And another issue is someone says I have antifreeze in my oil but when I looked at oil it didnt look like there was antifreeze in it, it just looked black. Need help asap
Welcome Aboard!(y)

Post any and all codes leading up to this.

Don't forget to introduce yourself and your Cruze here.
 
1 - 3 of 3 Posts
Top