Chevrolet Cruze Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
749 Posts
Discussion Starter · #1 · (Edited)
I was playing with a scan tool today while driving and was trying to find a way to check my def tank level. Normally the DIC shows "OK" until around 34-36% before it starts showing a number. Right now it just says "OK".

So monitoring while driving it showed my NOx reagent tank level at 100% constantly, then occasionally dipping to about 62% then back to 100%. It basically stays at 100% ... 99% of the time.

Is it normal for the system to show 100% like this? I recall about a month ago my def monitor showed 30 something percent then went back to OK and has been OK since. So I really don't know where it's at. I don't remember the last time I even added DEF. Curious if maybe there is an issue with the level sensor. I had the heater replaced under the warranty a few months ago.

I'm wondering if maybe the system is designed to only check the level periodically, otherwise it shows full. Can someone check theirs for me and see if shows the same thing?
 

·
Premium Member
Joined
·
2,697 Posts
What kind of scan tool are you using?

I have a Scan Gauge II but don’t recall seeing an ‘x-gauge’ option for DEF level...?
 

·
Registered
Joined
·
749 Posts
Discussion Starter · #3 ·
It's called OBDWiz. It's a PC based application.

The PID says SAE 0x85 but there are several other NOx sensors in that range too.
 

·
Registered
Joined
·
216 Posts
I use a scan gauge II. The "LVL" is to show the Diesel Exhaust Fluid Level as a % . Mine has always shown 100% and I fill the DEF tank about every 10,000 miles with a little over 3 gallons at a DEF pump.
 
  • Like
Reactions: BDCCruze

·
Registered
Joined
·
749 Posts
Discussion Starter · #5 ·
I use a scan gauge II. The "LVL" is to show the Diesel Exhaust Fluid Level as a % . Mine has always shown 100% and I fill the DEF tank about every 10,000 miles with a little over 3 gallons at a DEF pump.
Awesome. Thanks for sharing. I'll accept that as my car is operating normally.
 

·
Registered
Joined
·
533 Posts
I've had the car for 1.5 years and put 45k on it, so I'm familiar with refilling it. I was just confused over the reported 100% level when I know it's not.
Yeah, having it say good until it hits 35% kind of sucks, but gives you plenty of miles to fill up. I took it to 50 miles this last time and it still said 4%. $12.50 to fill up at the truck stop by the way.
 

·
Registered
Joined
·
2,994 Posts
I've had the car for 1.5 years and put 45k on it, so I'm familiar with refilling it. I was just confused over the reported 100% level when I know it's not.
when its cold, mine shows 35% when its full

or takes days to update after filling

does the gauge work that well? nope

is it an issue? nope....theres sooo much leeway, if someone were to run out of def, its totally on them
 
1 - 9 of 9 Posts
Top