Chevrolet Cruze Forums banner

21 - 40 of 79 Posts

·
Premium Member
Joined
·
7,930 Posts
Well, that sucks. Any idea how it failed? Might want to replace the oil supply line - just to be sure.

I'm curious on how it drives after you fix it. I'm thinking it's been sick for some time.

Out of curiosity, what brand of oil do you run?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #23
The oil inket line melted blowing all the oil out of the center section all over the bottom side of my car :/ thats what caused the center section to take a crap
 

·
Premium Member
Joined
·
7,930 Posts
Wait, you're saying the metal supply line melted? (It's the clean, insulated straight line that goes behind the manifold in the pic below.)

I guess it's possible that a melting return line could have blocked oil flow. But I'm not sure why the line melted when one one else has reported it.

Pic from the How to replace turbo oil feed line thread
 

·
Registered
Joined
·
25 Posts
Discussion Starter #27
No the inlet tube (runs from the bottom of the center section to the oil pan) not the feed lone, I mistook it by name. It was leaking pressure and oil so the center section couldnt retain oil to lube. I have it all buttoned up and its quiet again and drives like new!

Tha ks for the comments on the bike as well. That thing costs me more than this car and it isnt broke when i replace parts haha.
 

·
Premium Member
Joined
·
7,930 Posts
I'm a computer person. Working on cars in a apartment stall isn't my idea of a fun day.
 

·
Registered
Joined
·
990 Posts
No the inlet tube (runs from the bottom of the center section to the oil pan) not the feed lone, I mistook it by name. It was leaking pressure and oil so the center section couldnt retain oil to lube. I have it all buttoned up and its quiet again and drives like new!

Tha ks for the comments on the bike as well. That thing costs me more than this car and it isnt broke when i replace parts haha.
i don't get why gm calls it a inlet tube when it doesn't feed anything it drains it back into the block. Also did you have the old rebuilt or did you just buy a used one for 300?
 

·
Registered
Joined
·
990 Posts
inlet to the block
I know that but they call both the feed line and the drain an inlet. Just miss the days when it was called a drain line
 

·
Premium Member
Joined
·
7,930 Posts
Just to keep score, what oil were you using? I seem to remember a claim in another thread that only Mobile 1 users were reporting turbo problems.
 

·
Registered
Joined
·
990 Posts
Just to keep score, what oil were you using? I seem to remember a claim in another thread that only Mobile 1 users were reporting turbo problems.
I don't use it and mine failed.. It's mainly the ones made in Europe that fail and not the ones made In Mexico.
 

·
Premium Member
Joined
·
7,930 Posts
I don't use it and mine failed.. It's mainly the ones made in Europe that fail and not the ones made In Mexico.
Are you talking about the car or the just the turbo? Assuming you're talking about the turbo, any idea how to find the country of origin?
 

·
Registered
Joined
·
990 Posts
Are you talking about the car or the just the turbo? Assuming you're talking about the turbo, any idea how to find the country of origin?

The turbo housing is stamped
 
21 - 40 of 79 Posts
Top