Chevrolet Cruze Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hi I have a 2012 Cruze Eco 6speed manual with 75K miles and every now and then I get a quick smell of oil when I'm driving like a drip is landing on the exhaust or something. I opened the hood and peeked around. It looks like it is leaking up underneath the oil filter housing some place. Or at least that is the highest point where I see it coming from. Any other experience with this?
 

·
Super Moderator
Joined
·
7,786 Posts
O ring failure at the oil filter housing.

Who does your oil filter changes and please check you oil level?
 
  • Like
Reactions: obermd

·
Administrator
Joined
·
25,608 Posts
Or two o-rings instead of one.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
I do them and I always use a napa gold filter and new oring. It doesn't really look like it is coming from the oil filter, its underneath of it. There is a metal line going into the housing underneath of it that it looks like it is coming from.
 

·
Administrator
Joined
·
25,608 Posts
Clean the area under the filter housing then. Double check the cap only has a single o-ring and that the o-ring is seated properly. Then run the engine for a while to see if any new oil is leaking out. By cleaning the existing oil leak you will make it easier to find a leak as new oil will be more readily spotted. Checking the o-ring seating will eliminate a known, common issue around the oil filter housing.
 

·
Registered
Joined
·
57 Posts
I am having the very same issue only worse then you. Check my thread as well. I am narrowing it down to the gasket for the oil filter housing or the Turbo Oil return.

Though there are a lot of things down there with O rings. The oil Sending Unit Oil Cooler Lines Turbo Oil Lines ETC. I need to pick up some engine Degreaser and clean the area spotless as I can get it put the thing back together and run it a while and see where it's coming from. My issue is I didn't catch it in time and everything got covered in oil before it got bad.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 · (Edited)
e985fd72-b9ac-4f48-9c42-6eee53af09a4.jpg 386bdb68-2c11-461b-99ca-78198b77d0d3.jpg

Here are 2 pictures of where it is coming from. I tried to take one close up and one a little zoomed out. the spot where I circled on the oil filter housing is the highest point on the housing where I see oil so I know it isn't leaking out of the top of the oil filter housing and getting by the o ring. I did a little more research and people were talking about oil leaking out of the throttle body valve if you feel underneath of it. It is leaking there as well a tiny bit, but that is towards the back of the motor. This is on the front.
 

·
Registered
Joined
·
57 Posts
Yup same for me. Haven't figured out what the tube is yet.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
57 Posts
I wonder if it isn't the old sending unit they tend to leak when they fail.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #10 ·
It looks to me like it is coming out of that line whatever it is. After I get this handled then I have to figure out why there is oil leaking out of the throttle body. These are some leaky leaky motors.
 

·
Registered
Joined
·
57 Posts
Well mine had 170000 miles so can't complain. I have alldatadiy so I'll try and figure it out later. I'm on baby duty so wife can sleep.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #13 ·
Thats looks like what it is! Thanks!
 

·
Registered
Joined
·
57 Posts
Looks like what I have as well checking the local dealers now.
 
1 - 14 of 14 Posts
Top