Chevrolet Cruze Forums banner
1 - 20 of 22 Posts

·
Registered
Joined
·
719 Posts
Discussion Starter · #1 ·
I changed my oil yesterday and went to reset the OLM, and it won't reset. I've tried numerous times, but no luck. Every time I try, I go to the OLM, press the reset button, get the prompt asking, "Are you sure you want to reset?" select "Yes," and it goes right back to the OLM monitor at the same 13% it was when I went to reset it. I tried several times yesterday and two or three again this morning.

Anyone have this problem before?
 

·
Premium Member
Joined
·
1,958 Posts
I have not had that problem, maybe unhook battery cable and let set for a min, then rehook back and see if it will allow you to reset???
 

·
Registered
Joined
·
958 Posts
Just do it the old fashion way and change your oil by mileage. It sounds like you do now from changing it at 13% instead of 0%. More technology = more problems. Besides it might save you a bundle instead of fixing this insignificant problem.
Mine is currently 12% with 650 miles to go for my 5k oil change and I don't care what % it is when I hit 15k I'm making my 3rd oil change.
 

·
Registered
Joined
·
719 Posts
Discussion Starter · #4 ·
I have not had that problem, maybe unhook battery cable and let set for a min, then rehook back and see if it will allow you to reset???
That's my next thing to try.

Just do it the old fashion way and change your oil by mileage. It sounds like you do now from changing it at 13% instead of 0%. More technology = more problems. Besides it might save you a bundle instead of fixing this insignificant problem.
I use a combination of mileage and the OLM. Since I (now) do mostly city driving, whenever the OLM hits 20%, I'm ready to do an oil change. This time I made it down to 13% and just under 6,500 miles. Since I do a large amount of city driving, I'm mostly concerned about fuel dilution. I'm sending off a sample of my just-changed oil to see if my concerns are warranted.
 
  • Like
Reactions: IndyDiesel

·
Super Moderator
Joined
·
7,353 Posts
Did you use a dexos2 registered oil?
 

·
Registered
Joined
·
719 Posts
Discussion Starter · #7 ·
Did you use a dexos2 registered oil?
I used Amsoil European Car Formula 5W-30 - the new "Improved" formula that meets dexos2 spec.

Maybe that's my problem. Maybe GM installed a special RFID reader that will only allow a reset if a dexos2 bottle with a special chip is present. :wink:
 

·
Premium Member
Joined
·
7,353 Posts
"Are you sure you want to reset?" select "Yes," and it goes right back to the OLM monitor at the same 13% it was when I went to reset it. I tried several times yesterday and two or three again this morning.
So try selecting "no". Maybe you're not interpreting the highlight correctly.
 

·
Registered
Joined
·
719 Posts
Discussion Starter · #11 ·
Mine will only reset with the key on and engine off. If the car is running, it will let you go though the motions, but wont reset.
You know what, that thought crossed my mind, but now that I think of it, every time I tried, the engine was running. I guess I didn't try it with the engine off. I'll try later today.
 

·
Registered
Joined
·
355 Posts
I was freaking out the first time I tried to reset mine outside my dads dealership when he did my oil, I couldn't get it to reset. Then I got home and read the book, motor must be off.
 

·
Registered
Joined
·
958 Posts
So far I've changed the oil twice in my '13 cruze and didn't have a problem resetting. Must have done it with the engine off? But I usually start the engine after an oil change on all my vehicles just to run it then to check the oil level. While running it I make an entry in my pad of paper(maintenance logbook)date, oil, filter and mileage then reset the cruze while engine running I thought?
 

·
Premium Member
Joined
·
4,647 Posts
So far I've changed the oil twice in my '13 cruze and didn't have a problem resetting. Must have done it with the engine off? But I usually start the engine after an oil change on all my vehicles just to run it then to check the oil level. While running it I make an entry in my pad of paper(maintenance logbook)date, oil, filter and mileage then reset the cruze while engine running I thought?
Might be different with the gas Cruze
 

·
Registered
Joined
·
88 Posts
I think getting your oil tested for peace of mind is a great idea but I will be very surprised if you have any different result than the vast majority of the many many people who have questioned the OLM and tested oil over and over. And that result is almost always that the OLM is pretty well thought out, conservative and trustworthy.
 

·
Registered
Joined
·
719 Posts
Discussion Starter · #20 ·
I think getting your oil tested for peace of mind is a great idea but I will be very surprised if you have any different result than the vast majority of the many many people who have questioned the OLM and tested oil over and over. And that result is almost always that the OLM is pretty well thought out, conservative and trustworthy.
I totally agree, and the fact that my OLM was down to only 13% at about 6,400 miles was reassuring. However, my main concern is fuel dilution since I drive heavily in the city, and that can be an issue with the diesel especially in city driving (more frequent low-speed, less efficient regens). My last oil probably saw 80+% city driving, so I want a base to know if I should be changing more frequently.

I just shipped off my sample yesterday, so I should have my answer soon.
 
  • Like
Reactions: obermd
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top