Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
The vehicle in question is:
2012 Cruze LT w/ Manual 6 speed Transmission
154,000 miles (no warranty)

A single code P00C7 just popped up on my dash.
After doing a little research on this forum, it seems the culprit could be:

Manifold Pressure (MAP) Sensor - Rockauto @ $21.79
ACDELCO # 55567257

-or-

Turbocharger Boost Sensor - Rockauto @ $17.86
BOSCH # 0261230298

Both sensors contain o-rings that might have gone bad over time/mileage. I haven't been able to visually check the condition yet.

Has anyone dealt with this code and found a successful fix?
 

·
Premium Member
Joined
·
8,003 Posts
The code is set when the collective readings from the Barometric pressure, MAP, and Turbo boost/intake air sensor doesn't make sense but the ECM can't figure which one is wrong.

I'd also consider the possibility that something in the intake is not behaving normally. Such as a modified intake or major vacuum leak.

The PCV system tends to be a high fail item, so I'd make sure the plastic hose that connect to the intake is OK and the check valve works.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 · (Edited)
The plastic tubing connected to the throttle body was a little loose. That's all I noticed. I'll reset the code and hope for the best.
The car is running really good before and after the code set.
 

·
Registered
Joined
·
1 Posts
Hi Farmer, did that fix the code? Getting the same code now. Dealer didn't seem to want to work on it and blaming my CAI. Added it about 50k miles ago. I'm going to try to diagnose myself.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #5 · (Edited)
The code came back at 178,000 miles. I did an inspection and noticed a build up of oil/dirt around the throttle body. The check valve in the intake manifold failed.

I replaced the intake manifold and the code never returned.

ACDelco 25200449 GM Original Equipment Intake Manifold - $158
 
1 - 5 of 5 Posts
Top