Chevrolet Cruze Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All,

2013 Sonic LTZ with the 1.4L Turbo. Check engine light came on with the P0234, no other pending codes.

I am led to believe that my two options are to replace the turbo assembly or replace the MAP sensor.

MAP sensor could be at fault because it could be intermittently sending an overboost signal.

More than likely the wastegate isn't functioning properly and it is built into the turbo housing and must be replaced all together.


Let me know your thoughts or what else I should check.

Kind Regards
 

·
Administrator
2014 LT program car, Pull Me Over Red
Joined
·
12,122 Posts
Welcome Aboard!:welcome:

Possible Causes:
In lieu of further trouble codes associated with the overboost condition it would be safe to say the problem is mechanical. The operation of the wastegate is the most probable.
The wastegate is either stuck closed causing the turbo to spin higher than normal, thus causing the overboost.
The rod from the wastegate actuator to the wastegate on the turbo is bent.
A hose came off the wastegate or boost controller. A supply house to the boost controller or from the controller to the wastegate is clogged.


Read more at: https://www.obd-codes.com/p0234

[h=1]2011-2016 Cruze 1.4 PCV Valve Cover/Intake Manifold Issues[/h]
[h=1]2011-2016 Cruze 1.4L PCV System Explained[/h]
[h=1]Cruze/Sonic 1.4L Turbo LUV/LUJ Boost Leak Testing Kits[/h]

Don't forget to introduce yourself and your Cruze here.
 

·
Registered
Joined
·
1 Posts
I know this is an old thread, but I am having a similiar problem with my 2013 Buick Encore 99,000 miles which has the ecotec 1.4L turbo.

PO299

and secondary pO234 which did not show up with the scanner but it is listed.

Is this part responsible for boost at all?

293878
 
1 - 3 of 3 Posts
Top