Chevrolet Cruze Forums banner

P0299 and P0420 issues with 2013 Chevy Cruze LTZ

15282 7
Hello, I'm new to this post and this is my first post here, but I have recently purchased a 2013 Chevy Cruze LTZ six speed automatic, with 95,5xx Miles on it and have experience various issues, some slow, sluggish acceleration from a dead stop like the car is hesitating to get to higher RPM's and vehicle surging or rough idle while at a stop where the RPM's go down as low as 500 RPM's up to over 1200RPMS. I’ve only had this vehicle since May 12, 2017. So roughly 6 weeks and have had nothing but issues. About two weeks within owning it I get in my car and the CEL is on giving out a P0299 code which of course I look up and states under boost from turbo, I cleared it and no issue came up for the next two weeks. So, last week I'm driving down a busy street here in LAs Vegas where it was roughly 114' degrees and I’m switching from third to fourth gear with about 4500 RPM's and my car stalls out and lose all power from the engine, and check engine light came on but did not have my scanner handy, so after being towed into the dealership here close by and my battery dying since I waited for three hours in Vegas HEAT! They stated it was unable to be scanned due to having a dead battery and it needed to be replace with an addition of a new fuse block and positive cable. I couldn’t afford the dealership prices but paid the $167 fee for them to let me know my battery was dead which I knew (LOL), and I did replace all parts as my advisor recommended, and then my CEL came on again however this time with a P0420 code and I had my mechanic look at live data and stated that it was reading the P0420 code, however the catalytic converter was ok and doing everything it should also O2 sensors are reading as if the catalytic converter is good. So, he Reset the CEL and I drove away two days later my light returns on again and now I check my Codes today and see both the P0299 under boost from turbo and P0420 catalytic converter low efficiency below threshold from bank 1. I have replaced sparkplugs with acdelco that were OEM parts, also the ignition coils, oil change with full synthetic and ac Delco oil filter and transmission fluid since I did not know when any previous maintainence was done last. This was completed two weeks after purchase so right after the under-boost code was tripped. I know the turbo is still under 5 year/ 100,000-mile warranty but could the under boost also affect the catalytic converter? and I'm wondering is it okay to drive this vehicle to work in back till then its roughly 14 miles’ roundtrip a 10-min trip here in Las Vegas or should I drop it off sooner? I set an appointment for the dealership on Saturday @ 7:00am first available.

Thanks, in advance for any information.
1 - 1 of 1 Posts

· Registered
Joined
·
4 Posts
Same problems. This car has been a nightmare since I bought it in April of this year (2017) with 97k miles at a Toyota dealer. In May, I got the p0420 error and the cat converter had to be replaced. In august my water pump was leaking and that had to be replaced.

Just yesterday, I got the P0299 code popped up and the turbo replacement is $1.5k.

I submitted a complaint to GM. If they don?t help with the repair costs, I?m done with this car.

Btw, the warranty for the turbo should last until 100k.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top