Chevrolet Cruze Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello all, about 2 weeks ago i had a check engine light come up with P0299 Engine under boost. It went off on its own so i decided to wait and see if it came back on..... and it did yesterday. i have not hooked up scan tool back to it but im assuming that its gonna be the same code. it does seem to be lacking on power but im not sure if its in limp mode or just not building boost. is there anything real common with this that i can check for with or without the scan tool, i will hook the tool back up to it today and can give boost readings and so on. Any suggestions will be helpful thanks in adavance.



2012 Cruze RS LT
71k
 

·
Administrator, Resident Tater Salad
Joined
·
17,486 Posts
Usually the wastegate pivot pin is worn out. If your car is still under powertrain warranty, they'll replace the turbo for this code if it's still currently on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Nothing is under warranty as of last month or before but is the pivot pin easy to replace on my own or expensive?
 

·
Administrator, Resident Tater Salad
Joined
·
17,486 Posts
Nothing is under warranty as of last month or before but is the pivot pin easy to replace on my own or expensive?
It's all cast as one piece with the exhaust manifold, so the whole turbo needs to be changed.
 

·
Registered
Joined
·
253 Posts
On my 2011 i had the clip that held the arm on break. that could be all it is too. Take the heat sheild off and see if the arm fell off. If it did you can use a c-clip to secure it back on.
 

·
Registered
Joined
·
319 Posts
So speaking of UnderBoost and pivot pin wear, Mine pivot pit is super worn out like .35-40"..Car will not throw a underboost code, I even went as far as opening up the wastgate and holding open with some visegrips and drove around with no power for like 30 miles, nothing, no code, had zero power(I'm trying to get a new turbo before my 5 year runs out)....Gm did a real good job with that emmisions recall and that hidden program that will not throw p0299 codes...! I'm guessing the OP never had that recall done...
 

·
Registered
Joined
·
253 Posts
How many miles did you have on your car to have that much play in the pin. I had over 100k before the clip broke. After i replaced the clip I drove probably another 15k and it was fine.
 

·
Registered
Joined
·
12 Posts
Are the replacement turbos an upgrade over the ones that are failing? My 2015 has had the cel on twice for P0299 code. First time i cleared it because i found the fender insulation in my intake box. It came back on during my roadtrip at 54k miles. I heard that the new turbo pivot pin won't have the same issue?
 

·
Registered
Joined
·
6 Posts
On my 2011 i had the clip that held the arm on break. that could be all it is too. Take the heat sheild off and see if the arm fell off. If it did you can use a c-clip to secure it back on.
It is just the three bolts holding on the heat shield right. I have the same problem. Is there any way to check it without removing the heat shield? I cant wiggle it or something to check it?
 
1 - 9 of 9 Posts
Top