Chevrolet Cruze Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Anybody else have this code on the gen 2? Just popped up for the first time today. I read and cleared the code. Will see if it comes back tomorrow.

When searching for the code, i found that apparently this was common on gen1 cars, but don’t see much on gen2.

Car is 2017 premier hatch, 47k miles


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
Just this week I had a P0299 code.
I think I had an over pressure excursion after leaving the red light with a heavy foot and heard a very lond bang from the engine area.
After further review, I had to push the inlet air tube back on to the throttle body. Plan on going to the garage for a new gasket and spring ring clamp at teh throttle body.
 

·
Registered
Joined
·
6 Posts
If the codes comes back. Do a compression check. Possible cracked piston land. Also you remove oil cap when it running to see if you have back pressure in the crankcase.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
My code never came back after i cleared it. I am not going to worry unless i see it again


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
Follow-up a Garage report for Gen2BluRS.
codes P0299; P0101 and P1101. They change the Intercooler (Air Cooler 13356681) they cited it was pulgged and the plastic tube to the throttle body was cracked so it got replaced..
The Chevy indicated it was the first intercooler they changed on a Gen 2. 38K for mileage.
They reported the bang I heard was a back fire... Didn't know that could happen on a direct injection engine.
 

·
Administrator, Resident Tater Salad
Joined
·
17,075 Posts
The hose popping off isn't terribly uncommon, but this is the first I've heard of an intercooler needing to be replaced that wasn't smashed.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Update from OP here...check engine light came back on a couple weeks ago. Didn’t take the time to read the code but I am pretty sure it is still turbo underboost. Was waiting until after the holidays to take it to the dealer. The check eng. light clears itself after 3-4 startups, so it seems intermittent.

This morning on the way to work i was going up a mountain on the interstate, and i felt the power loss at the same instant i could see the check engine light come on in my peripheral vision. Engine just completely fell on its face and was low on power the rest of my drive to work. Hopefully this can be covered under 60k powertrain warranty.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
12 Posts
I’ve been fighting the same code for the past 3 weeks. Comes on and the car is sluggish then the light shuts off 2 days later and car accelerates fine again. Called the dealership and they won’t help me unless the light is currently on. But their scheduled appointments are always booked out 3-4 days so by the time my appointment happens, the light shuts off the day before. So frustrated. Car has 78000 miles and is drive 110 miles a day. Any options?!?!?
 

·
Registered
Joined
·
1 Posts
I’ve been fighting the same code for the past 3 weeks. Comes on and the car is sluggish then the light shuts off 2 days later and car accelerates fine again. Called the dealership and they won’t help me unless the light is currently on. But their scheduled appointments are always booked out 3-4 days so by the time my appointment happens, the light shuts off the day before. So frustrated. Car has 78000 miles and is drive 110 miles a day. Any options?!?!?
I was in the same situation where the appointment was always 3-4 days out and the light would go off, so right as soon as the light came back on I drove straight to the dealership. Told them, im not looking to get it fixed today but I want you to diagnose the issue so we can schedule a day to bring it back to have it fixed.
 

·
Registered
2018 Cruze Hatchback RS Premier
Joined
·
114 Posts
I was in the same situation where the appointment was always 3-4 days out and the light would go off, so right as soon as the light came back on I drove straight to the dealership. Told them, im not looking to get it fixed today but I want you to diagnose the issue so we can schedule a day to bring it back to have it fixed.
That's exactly what I've had to do in the past with a different car/problem. They seemed irritated but it helped me get the problem acknowledged by the service department and made the appointment meaningful.
 

·
Registered
Joined
·
12 Posts
finally diagnosed the problem at the dealership and they said that the turbo needs to be replaced. I'm looking into other options for replacement now as they quoted me $1600 for the entire job. Any recommendations for replacement turbos? just seems sketchy that this wouldn't be covered by the dealership if so many model and years of this car are having this same issue.
 

·
Registered
Joined
·
829 Posts
They're trying to charge you for it? Aren't you still under the 5yr/60k powertrain warranty?
 
  • Like
Reactions: jcountry

·
Registered
Joined
·
12 Posts
Im not under the warranty anymore. its got 80,000 miles now. I do 110 miles a day for my work commute.
 

·
Registered
Joined
·
829 Posts
Oh **** that sucks then. I only saw the post where you said you have 49k on it. I know BNR made turbo kits for the Gen 1 cars but they don't have anything (as of right now) for the Gen 2. Looks pretty simple to replace and the Stigan ones seem to have decent prices. No word on them though
 

·
Registered
Joined
·
12 Posts
Yeah it sucks. Don’t know if I should start with the ZZP wastegate actuator first since the underboost code is intermittent. But will probably get a second opinion from another dealership.
 

·
Registered
Joined
·
829 Posts
It's a cheaper option for sure at least, probably not a bad place to start
 

·
Registered
Joined
·
24 Posts
This just happened to mine when it had around 110k or so miles. Im in central IL where the weather has been horrible.. The dealership said my car is the fourth one in the last week with that issue. Apperently the intercooler freezes up being outside (its been in the negative temps at night for the last two weeks.) Otherwise, some days the car has no power, then other days it runs like normal.
 

·
Premium Member
Joined
·
2,132 Posts
This just happened to mine when it had around 110k or so miles. Im in central IL where the weather has been horrible.. The dealership said my car is the fourth one in the last week with that issue. Apperently the intercooler freezes up being outside (its been in the negative temps at night for the last two weeks.) Otherwise, some days the car has no power, then other days it runs like normal.
And this is why the 18-19s have software to inhibit 6th gear when cold and humid out
 
1 - 20 of 20 Posts
Top