Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
What’s up everyone this is my first post. Hopefully someone can help. Got a bad knock, loss of power/mpgs. Almost no power once car is heat soaked.
So I’ll start with what I’ve looked at. Re sealed my pvc thought about air leak no leaks cracks and is still working properly, looked at two screws on timing belt guide they are tight. Checked my lifters(I pressed down on them with some body weight with screw driver none moved checked the sparks they are tight as well. Soo I tried what most people suggested. Except a oil change and new sensor which I have just have not put on yet. I don’t have oil loss or blue smoke or burn smell but oil is pretty dark to be fairly new. It’s 5-30 Amsoil??? It’s suppose to be good AF but it’s pretty dark like coffee put it in the car around October 19’.

I have a new head on this thing it’s a brand new GM head came with new lifters and cams so I don’t believe it’s the lifters cams were not scratched at all.
Bought the pvc kit from Andre(xtreme) that fixed my blue smoke and bad Mpgs great buy by the way really woke the engine up and easy to install plus the big 3 kit.
Bought the MSD coil pack last month another great buy,I wish I did when I 1st got this thing.
MPfab cold air intake w Amsoil filter and honeycomb
Sparks are ac d brand new. Did not touch them so they are at .24
My Cat is (Gutted) so always have p0420 but that also freed up my turbo did not affect mpg’s Went thru at least 5-8 tanks on it with no issues.
everyday car for me 166010 miles , I’m pretty familiar with how the car feels and if I’m having misfires etc. but this one has stumped me as of now. I plan on changing oil when I get back to my office today and mess with the sensor. Just wondering if any one has any advice on what I just described. Again oil consumption seems fine.
please help!
All last year car was in out of the shop. Last person to work on it was Chevy dealer in Nov 19’ to set timing chain correctly Came back great! I just don’t want to fork over more money again. I want to believe it’s not a piston issue my because I think I would (feel) that my knock is just loud noise that gets worse with higher rpm’s running premium Shell/chevron
Thanks.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
So I changed oil. Metal in my filter. There was metal in old filter I found from last oil change. The Amsoil got burnt it was really bad super thick and dark I think it’s definitely a piston ring or worse. It has 166000+ think its time for a new engine. Anyone have some thoughts on changing 2012 LUJ to 2015 LUV found the LUV on eBay I’m considering buying.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Bought a 1.4L on eBay with 16,000 miles on it. Hope to get 200,000 out of this one! With all the knowledge and upgrades I have it should be a goal I can achieve with this car.
 

·
Super Moderator
Joined
·
7,475 Posts
Bought a 1.4L on eBay with 16,000 miles on it. Hope to get 200,000 out of this one! With all the knowledge and upgrades I have it should be a goal I can achieve with this car.
This is the first I've seen of your post. There are at least two or three threads on swapping engines. As for the gutted cat, you would be better off if you buy a tune from any of the tune vendors to help with that.
 
1 - 4 of 4 Posts
Top