Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
ok so heres what happened.

i do about 40 km of city driving a day. max i get to is maybe 80kms an hour for short bursts. i know this isnt ideal for these newer diesels. so on friday i was heading to pick my daughter up which is a 2.5hr drive one way. i got about 1/4 the way into my trip and the CEL came on. no drivable concerns. still lots of jam under WOT. no messages on the dash. i am aware the code is DTC P20EE NOx Catalyst Efficiency Below Threshold. i havent had to add DEF since march. im at 25000kms. i was going aproxx 125km at the time when the code set. i maade it to the next GM dealer i could and they scanned it and cleared the code.

so what im woundering is does any one have experiance with this code? my car is running fine. driving normal. starting fine and my cruise control is working. the light is off now because of them clearing it.
 

·
Premium Member
Joined
·
4,652 Posts
I think a couple other people had NOx sensor issues and I think the general consensus was that those who don't drive their cars hard enough can potentially soot up the sensor.
 

·
Registered
Joined
·
209 Posts
I had code DTCP11D7-00 NOX sensor. I had interrupted the regen cycle several times. The dealer cleared the code and all was well, but after a week the dealer recommended that I change the sensor since it is under warranty.
 

·
Premium Member
Joined
·
373 Posts
You need a Nox sensor. Go to dealer. wait a few weeks for part . go get your car. Hope the sensor fixed your problem. Be glad your car didnt start a death countdown.

You shouldnt have to run your car hard. You shouldnt have to make excuses for your car. I have gotten that code and tried all kinds of driving techniques with no luck.
 
1 - 4 of 4 Posts
Top