Chevrolet Cruze Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all fellow Cruzers! Hoping I can find some info and or guidance with my issue. I have a 2014 1 LT with 123K miles. About a week ago I got a P2227 with a pending P0234. I did some forum searching and even a post on FB CruzeTalk that suggested a new MAP sensor, got that. I was due for changing spark plugs this weekend so also did that.

I had the common coolant leak issue so also over the weekend I replaced the coolant housing and thats done. Im going into Limp mode when the solid check engine light fires up.
Last week I checked and cleaned the MAF and it was really clean but gently cleaned it anyway with the MAF cleaner spray.

Im praying for anyone thats had a similiar situation or any useful info. The car has zero leaks and im not over heating one bit.

Thank you all~
 

·
Registered
Joined
·
3 Posts
Hi,
Izaacg816, did you ever figure this out? I have the same codes.

Others - I have the same codes. You can hear an audible ticking noise when the vehicle runs and you can feel the engine hesitate when accelerating. I also noticed what I think is my catalytic converter (or at least the piping just before it) is orange hot after driving. This is only visible in low light conditions.
Occasionally, my car will surge when stopped at red lights. The surging at lights has been happening for a while where as the hesitation and ticking are new. Edit: The ticking has always been there but now it has gotten much louder.

Ideas:
- engine is attempting to fix a lean condition due to vacuum leak and overcompensating?
- spark plugs are somehow fouled? (Were changed at dealership 40K kilometers ago when coil bar was replaced)
- inadvertently being overdue for an oil change caused the oil to sludge up and the engine cant distribute heat causing pre-ignition?

I tried to look for sludge. I attempted to pull the cam cover but it was stuck. The DIY here warned against wrecking a seal so I did not pry.
 
1 - 2 of 2 Posts
Top