Chevrolet Cruze Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1
Hey guys, been a while since I've had an issue but seems that has changed. I seem to be having smoke coming from the exhaust when I'm under heavy throttle. It only happens between shift. It's a 2012 Eco so I know bout the ring land issue. I'm just hoping it's the turbo and not engine. I got 92k so the turbo seems logical.
 

·
Registered
Joined
·
1,164 Posts
compression and leak down test will pin that down or a bora scope.Based on your mods i would say you may have helped a weak piston along
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3
I took the dp off to take a look at the turbo shaft for play and found none. So I'm leaning toward the Pistons too. I'm in the process on finding a shop to do the test or just buying the tools and doing it my self.
 

·
Registered
Joined
·
990 Posts
I took the dp off to take a look at the turbo shaft for play and found none. So I'm leaning toward the Pistons too. I'm in the process on finding a shop to do the test or just buying the tools and doing it my self.
You can rent the tool from most auto parts stores also did you pull this intercooler piping and check for oil?
 

·
Registered
Joined
·
213 Posts
Discussion Starter #5
Yeah I recently took it off and cleaned it out. I had a thin film in the pipes and cooler. I figured it was just blow by. But I'm starting to think this might have been an issue the whole time I've owned the car. I just haven't noticed it until I took out the cat on the midpipe
 
1 - 5 of 5 Posts
Top