Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I bought my wife a 2012 Cruze 1LT new in January 2012. This car has been a complete nightmare. The first year we had it, it was at the dealer for driveability issues. It has been in and out for other mechanical issues. The battery went bad in the first 18 months. The dealer wouldn't warranty it. But now to the problems we are having today. My wife was driving home and CEL came on and the alert to service stabilitrac and traction control came on then went off. Car was running very rough.

She got it home. I drove it, it was a little rough but much better than what she experienced. I went and gassed it up and drove it up and down the highway. It drove better, but not perfect. I got home, showed the wife that it was running better. Turned it off then restarted it, and it was running even rougher. Very low idle.

Codes are p0106 p1101 p0171

it has 59k miles. A car with 59k shouldn't have these problems.

thank you
 

·
Premium Member
Joined
·
25,596 Posts
First, pull the reciept for that battery and send it to GM. The battery is covered under the B2B warranty and you should NOT have had to pay for a battery in the first 3 years or 36K miles. Second, take your car to a different dealership. P0171 is a vacuum leak and is most likely the PCV valve/camshaft cover, which is covered under the power train warranty (5 years/100,000 miles).
 

·
Premium Member
Joined
·
3,975 Posts
What Obermd said, plus tell us the name and location of the dealership so the rest of the Cruze world can avoid them.
 
  • Like
Reactions: JeffBazell
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top