Chevrolet Cruze Forums banner
1 - 20 of 45 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Hey guys, new guy here. Just purchased a 1.4 Cruze 1LT RS and I love it. It doesn't make sence to me why these cars didn't come factory with a boost gauge as minute as the boost may be. I'm installing a boost gauge because I'd like to keep track of what the turbo is doing.

Ive purchased a boost gauge from AEM and have it installed however I only seem to be reading vac. I've posted a pic of where I tee'd into the black and green hose. Did I tap into it on the wrong side or something?
Please help. I'd like to get this behind me due to a busy schedule.

Thanks fellas.


 

·
Registered
Joined
·
34 Posts
Probably tapped into the wrong spot. Make sure it is right off the intake manifold. Never added a gauge to a Cruze, but I have to several Saabs over the years.

As for boost being minute, I had one of the those bluetooth odb things with the torque app on my phone and it was reporting over 12psi. If I recall correctly...
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #4 ·
Thanks jie. Took the car out on the road this morning to take the kids to school. I'm guessing that if your revving the car while its in park its not seeing any boost? When I reported it was only seeing steady vac it was right after install and in park in the driveway just revving it up.

While out on the road I was seeing approx 12lbs every now and again but spends most of its time in vac. Surprising to see that you ALMOST have to try to get the car to boost and with my normal driving habits I don't see any often.

Does this sound normal? It's an auto if it makes any difference.
Im good with NA motors but this is my first FI vehicle I've ever owned.
 

·
Registered
Joined
·
576 Posts
Thanks jie. Took the car out on the road this morning to take the kids to school. I'm guessing that if your revving the car while its in park its not seeing any boost? When I reported it was only seeing steady vac it was right after install and in park in the driveway just revving it up.

While out on the road I was seeing approx 12lbs every now and again but spends most of its time in vac. Surprising to see that you ALMOST have to try to get the car to boost and with my normal driving habits I don't see any often.

Does this sound normal? It's an auto if it makes any difference.
Im good with NA motors but this is my first FI vehicle I've ever owned.
I am tuned and I push just over 21 PSI based on my boost gauge. Unless you are driving, the gauge will show as vacuum. Are you tuned? If not, the PSI you are seeing may be the normal stock amount. I did not have a gauge before so I have never seen it that low.
 

·
Registered
Joined
·
13 Posts
While out on the road I was seeing approx 12lbs every now and again but spends most of its time in vac. Surprising to see that you ALMOST have to try to get the car to boost and with my normal driving habits I don't see any often.

Does this sound normal? It's an auto if it makes any difference.
Im good with NA motors but this is my first FI vehicle I've ever owned.
This sounds pretty normal to me but my experience isn't very extensive. I've been using the Torque App for a a few days now and it seems to take a fair amount of throttle/RPMs to get some boost going. When I do get on it I seem to be peaking at 17.5psi compared to your 12. I'm not sure how accurate the Torque App is though.
 

·
Registered
Joined
·
2,994 Posts
Thanks jie. Took the car out on the road this morning to take the kids to school. I'm guessing that if your revving the car while its in park its not seeing any boost? When I reported it was only seeing steady vac it was right after install and in park in the driveway just revving it up.

While out on the road I was seeing approx 12lbs every now and again but spends most of its time in vac. Surprising to see that you ALMOST have to try to get the car to boost and with my normal driving habits I don't see any often.

Does this sound normal? It's an auto if it makes any difference.
Im good with NA motors but this is my first FI vehicle I've ever owned.
you bought an econobox, built and tuned for mpg.

more boost = more air in the cylinder, along with more fuel for that air. to maintain air/fuel ratio...more boost = less mpg.

if you drive it as the car is designed, youre not gonna see crazy boost, hence the lack of boost gauge.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #8 · (Edited)
Sounds good guys. The more I drive it the more I was starting to realize that it was hooked up correctly and that's the amount of boost I'm going to see.

Yes, I bought this car for the mpg and I liked the looks as well. I have a Dodge Challenger SRT8 sitting in the garage if I want hp.

I will however be getting a tune from either Trifecta, or Vermont. What's your guys's opinions on these tunes and what's your reasoning for the one you picked.

From what little I know, I like the Trifecta tune because of the difference when putting the automatic in manual mode to driving it in fully auto and I plan on a ZZP down pipe for my Air/Fuel gauge, a BNR throttle body spacer because I want to replace the hose that I T'd into because I don't like the way it is and cold air intake from Injen.

I haven't done much research on Vermont but the man seems incredibly "up" on laws and regulations for his tune.
Either way I want the car as dependable after the tune as it was streight out of the factory.

Great conversation piece guys, let's keep this going. I'll take all the info I can get.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #9 · (Edited)
Just ordered the Throttle Body Spacer from BNR. Looks like an incredibly nice piece.



Now if ZZP would ever decide to get there down pipe back in stock........
After the CAI I'm done with the mechanic part and I'll start on the cosmetics.

I already have the front and rear LED lighting for the interior from DD that's been sitting on the shelf along with the top of the line LED fogs. Gonna throw them in to give the kids the wow factor....... Well maybe for dad just a bit too.
 

·
Premium Member
Joined
·
906 Posts
Need help with Boost gauge (Pic)

I’m Trifecta tuned with an intake, catless dp & mp and the plugs gapped at .27 also have both a mechanical boost gauge (tapped into same black and green hose) and an Ultra Gauge. In eco mode I may see 15-16 psi max with an occasional spike to 17. In non eco mode I bury my 20 psi mechanical gauge and via the Ultra Gauge peek at 24.6 psi.

When you put the dp on and let that little baby turbo breathe it will spool with ease. With 170k mine is good and broke in and all you can hear is the turbine screaming even under idle.. There is your wow factor..

My problem are misfires due to the shitty and under powered coil pack, but I will say on days it decides to cooperate it pulls hard for a borderline 200hp econobox netting 44+mpg..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
576 Posts
Just ordered the Throttle Body Spacer from BNR. Looks like an incredibly nice piece.


Now if ZZP would ever decide to get there down pipe back in stock........
After the CAI I'm done with the mechanic part and I'll start on the cosmetics.


I already have the front and rear LED lighting for the interior from DD that's been sitting on the shelf along with the top of the line LED fogs. Gonna throw them in to give the kids the wow factor....... Well maybe for dad just a bit too.

I had the DDM Works TBS and switched to the BNR one. It looks a whole lot cleaner imo.


As for the Downpipe, check in with BNR. They just released theirs and it has been in and out of stock pretty regularly and is made of better material. They also back their work. ZZP has been having some weld cracking concerns now that they are a few years old and don't warranty them.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #12 ·
Maybe ill stick with BNR for the DP then. Thanks for the info.
Also.... maybe ill look into the BNR coil pack as well as you and i will have almost the same set-up. But that little bit of hp in that little car with that kind of MPG sounds mighty good to me.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #13 · (Edited)
I’m Trifecta tuned with an intake, catless dp & mp and the plugs gapped at .27 also have both a mechanical boost gauge (tapped into same black and green hose) and an Ultra Gauge. In eco mode I may see 15-16 psi max with an occasional spike to 17. In non eco mode I bury my 20 psi mechanical gauge and via the Ultra Gauge peek at 24.6 psi.

When you put the dp on and let that little baby turbo breathe it will spool with ease. With 170k mine is good and broke in and all you can hear is the turbine screaming even under idle.. There is your wow factor..

My problem are misfires due to the shitty
How does your exhaust sound with the DP and MP?
Did you install both at the same time?
If you didn't, was there a difference between before and after you installed the MP?
Are you able to keep the rest of the exhaust stock after the MP?

I don't want to turn this thing into a cheesy ricer and have every kid on the road lining up with me at every light but I do want to increase the engines air flow. I kind of like how quiet it is now but wouldn't mind a little more aggressiveness out the tailpipe.

Also, will the Trifecta tune take all of these things into consideration before they send me the tune.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #14 · (Edited)
Well ****! Went to install the Diode Dinamics XML2 LED fogs. Didn't fit. Different attachment for the projector fogs. That sucks. Looks like that's gonna take a back seat. I'll hook up there LED interior lights with remote tomorrow and post some pics.

Also I had issues with the Boost gauge freaking out then reading three dashes. Traced it back to an issue with the harness plug. Seems when plugging it in the ground pin was pushing down and out of the clip instead of going into the female end of the plug and barely making contact. So that's fixed now.

Got the shipping notice from BNR for the throttle body spacer.
When installing this, do you have to relearn the throttle body after hooking it back up? If so, what's the process?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #15 · (Edited)
Just ordered up the BNR Down Pipe. It'll be nice to open the exhaust up a little bit, not to mention get my wide band hooked up.

Will this DP throw a check engine light?

If so, I'm gonna have to wait until I'm set up with the Trifecta tune before I install it.
 

·
Premium Member
Joined
·
906 Posts
How does your exhaust sound with the DP and MP?
Did you install both at the same time?
If you didn't, was there a difference between before and after you installed the MP?
Are you able to keep the rest of the exhaust stock after the MP?

I don't want to turn this thing into a cheesy ricer and have every kid on the road lining up with me at every light but I do want to increase the engines air flow. I kind of like how quiet it is now but wouldn't mind a little more aggressiveness out the tailpipe.

Also, will the Trifecta tune take all of these things into consideration before they send me the tune.
No I had my dp long before I got the mp. It definitely opens up and let’s the turbo breathe and you can hear the turbine pretty good. Once I put the mp on it did change the sound quite a bit but in a good way. It has more of that jet turbine sound, the only time you can hear it is when you are in the throttle, and yes everything past the mp is still factory. If you stand behind the car at idle you can hear the turbo through the exhaust and is a low hum.

It’s still quite and most people just get in not knowing any different, once I get into the throttle a little and they hear It spool then the blowoff they are like holy S man.. also saw a bump in mpg also..

Yes trifecta will send your time with the adjustments needed and you will be able to go in and turn off the CEL on P0420 for the missing cat..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #17 ·
Thank you gentleman. I appreciate the great advice. Looks like the tune is coming sooner than later.

Whiteandbright, sounds like that's what I'm looking for in the exhaust. Do you have a video posted anywhere of a sound clip?

Also, can I change the title to my thread. It's evolved into something different obviously.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #18 ·
Just ordered the correct fogs from DD along with a harness to run the fogs directly off the battery.

Ordered the silver plastic cover piece at the bottom of the steering wheel from gmdirect.
Im gonna wrap it before I put it on, then wrap the rest of the bright silver inside.

Never got around to hoo kind the interior lighting up. Maybe this coming weekend.

Thinking about getting the Windows done. My challengers both have 35% all around with the whole windshield at 50. I'll probably do the same with the Cruze.
 

·
Registered
Joined
·
34 Posts
Thanks jie. Took the car out on the road this morning to take the kids to school. I'm guessing that if your revving the car while its in park its not seeing any boost? When I reported it was only seeing steady vac it was right after install and in park in the driveway just revving it up.

While out on the road I was seeing approx 12lbs every now and again but spends most of its time in vac. Surprising to see that you ALMOST have to try to get the car to boost and with my normal driving habits I don't see any often.

Does this sound normal? It's an auto if it makes any difference.
Im good with NA motors but this is my first FI vehicle I've ever owned.

Sounds about right. You won't get any boost in neutral/park because there isn't any load on the engine. I've found with an auto, boost isn't as easy to provoke. With a manual you stay in a taller gear and the boost will build up easier because of the load but with an automatic the transmission downshift when you step on it and there is less load on the engine. I wish the manual (L on the '16.5+) mode would prevent downshifts as well as upshifts so I could use the engines lovely midrange torque like I did on my '15 eco MT.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #20 ·
Just an update fellas.

Got the DD LED fogs in.
They match the DRL perfectly. Wish we could fit some HID in there because while they are bright, I miss the lumens of the HID bulbs.

Having some issues with the passenger side. The inside of the projector fogged up pretty bad after driving in a storm so I took the bulb back out, dried everything with a heat gun, cleaned the surface that the bulb assembly seals to and let it ride. It hasn't fogged back up yet but now the pattern is thrown off.
Gonna take it apart this weekend and see what's going on.

Recieved the throttle body spacer and DP. Waiting to install until after I get the tune. Could be a while. Next purchase will be wheels so tune could be a bit.

Recieved the steering wheel piece and yanked the rest of the silver pieces out of the interior. Tonight I just got done spraying the parts with base coat. I'll clear them in the morning.
I attempted to wrap them but I'm a little too picky and couldn't get it to my liking so I decided to spray them. I used to paint cars for a living so I know I could get them right going this way about it.
Ive done almost all my cars this way because it livens up the interior and makes it different from a lot of others. I'll post pics of base coat tonight and after I clear them I'll post more.
After I wet sand them and install them I'll post final pics.
At a later time I plan on yanking the speaker rings and doing those as well but I don't want to over do it. Sometimes less is more and again, I don't want this thing to look like a riced out ride and want to keep it classy.

Still have yet to install interior RGB LED's under the dash and seats. Kids are loving it so far and so is dad. This is probably the cheapest car I've ever owned but I gotta tell ya, i am impressed.












 
1 - 20 of 45 Posts
Top