Chevrolet Cruze Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter · #1 · (Edited)
well i bought a 2012 about 4 months ago and ive noticed a few things wrong

- my dic does not display engine coolent temp, instead i have a blank screen where it should be
- my friend has told me he has seen my drivers side fog light flicker on bumpy road ( cut out and flash )
-and this morning my passenger window does not move or make any noise as if it intended on moving with
no click of the relay
also my engine idles around 500 rpm and i asked members of the fourm by creating a thread and it seems im alittle low compared to others

i only have just under 6000 KM

ive seen on youtube videos that the dic is also supposed to display if traction control is on or not
also ive seen that there are also suposed to be like little tabs on the side of the screen that tell you
what page of the dic you are on for the corrisponding menu.

i have almost every pakage added to my car but nav, tmps, ltz, so im wondering if its only ltz that gets thoes dic features mentioned above?
i have the supervision cluster so shouldent i have it to?

was there a recent update done to the car that i may not have?
i orded my cruze on the last week that we were alowed to place orders for 2012's so i figure i should have all firmware , software, ecu updates ect.....

what are your thoughts?
do you have it too?

also to stacy:

what steps should i take befor bringing my car in and can you tell me if my car is up to date if i give you my vin?

thanks to all in advance

ru5ty :)
 

·
Premium Member
Joined
·
5,158 Posts
The tabs were a 2011 only thing. The 2012's don't get them.

It might be a Canadian thing. My Eco has coolant temperature under the "vehicle information" section.
 

·
Administrator
Joined
·
25,596 Posts
My 2012 ECO MT show the coolant temp in the Vehicle information area as well. There is also one blank screen there. The Traction Control and Stabilitrac are a pair of idiot lights on my dash. If the're flickering they're engaged. If they're solid on the systems are off.

Take your car back to your dealership and have them resecure the physical and electrical connections for that fog lamp. Something's come lose. Idling at 500 RPM is low, but after looking at the thread here about idle speeds it appears to be within the normal range. If it's a rough idle, that's a problem. Your window sounds like the relay or motor went out - once again, take it to your dealership.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #6 ·
thanks obermd will do, i wonder my my dic does not show coolent temp
 

·
Administrator
Joined
·
25,596 Posts
I've heard that some of the later 2012s don't show the engine temp in the DIC. If that's true, then someone at GM needs to seriously get out and talk to car enthusiasts about what displays they want in the car.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #8 ·
spervision cluster is not worth poop is i dont get extra options [email protected]#@$%@ lol i just went through the owners manual and engine temp is not listed pages 5-23 to 5-25. is it in the american manual?
 

·
Administrator
Joined
·
25,596 Posts
Interesting - the on-line manual (PDF) shows

. Units
. Tire Pressure
. Remaining Oil Life
. Battery Voltage
. Blank Display

My printed owner's manual shows

- Units
- Tire Pressure
- Remaining Oil Life
- Coolant Temperature
- Battery Voltage
- Blank Display

My printed manual is Part No 20935335 A First Printing
The PDF I have is Part No. 20935335 B Second Printing

There was obviously a change in the DIC displays and owners manual sometime during the 2012 model year.
 

·
Banned
Joined
·
2,226 Posts
Well rusty...Cant say that ive had any issues with my cruze. I know its normal for the engine to idle around 500rpm when in park or stopped. Not sure about ur other issues. I would say u have a bad relay or switch? Not even know what to say about the dissplay issue.
 

·
Premium Member
Joined
·
6,918 Posts
Engine RPM(500-600) after warming up & being i gear is totally normal. when cold mine runs about 1500rpm for a few minutes then drops back to 800 or so until fully warmed up.

I also read GM removed the temperature readout on the DIC about mid-model year 2012. Mine has it(January build date). Wonder if this was the same time they removed the tire pressure relearn procedure?
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #12 ·
im going to bring my car in to get checked, see what they say , its not that the 500rpm is affecting everything it just keeps me on edge cause i think its gonna stall. also seeing the needle bounce between 500-1000 rpm is wierd. ive never had a car that would do that. my mazda would always idle at 600 rpm. not this ramdom rpm a day thing. like you could literaly gamble on this thing cause its never constant. could be a new attraction at a casino.
 

·
Premium Member
Joined
·
902 Posts
My 2013 doesn't have engine temperature either. So it must have changed...I wouldn't mind that info in an quick to read location
 

·
Administrator
Joined
·
25,596 Posts
im going to bring my car in to get checked, see what they say , its not that the 500rpm is affecting everything it just keeps me on edge cause i think its gonna stall. also seeing the needle bounce between 500-1000 rpm is wierd. ive never had a car that would do that. my mazda would always idle at 600 rpm. not this ramdom rpm a day thing. like you could literaly gamble on this thing cause its never constant. could be a new attraction at a casino.
A needle bounce at idle is an indication your cylinders aren't all firing consistently. This is a potential drivability issue as a car stall at a stop light can be dangerous. The easiest thing to check on this is spark plug gaps. The ECU assumes the plugs are gapped consistently and will have problems controlling the engine RPMs if they are not.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #15 · (Edited)
ive gapped them to .35

it does not bounce its just every day i idle at a different rpm
 

·
Premium Member
Joined
·
6,918 Posts
I suspect your car is not fully warmed up when you are seeing higher than 500-600rpm idle. Like I said it idles about 800-900rpm until fully warmed up. That is besides the initial high idle of 1500rpm in cold weather, which I have not seen my car stay at for more than a couple minutes.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #17 ·
well i bought a scangauge2 on amazon so that will solve the temp display problem , should be here the 6th. also i removed the switch panel on the driver side and found that the plug for the passenger windows had disconnected from the panel so its plugged back in lol as for rpm ill try resetting the car, how long does the battery have to be disconnected for? i have a k&n installed and new muffler, maybe that is why the rpm is low. it has not been reset to relearn afr and such.
 

·
Administrator, Resident Tater Salad
Joined
·
17,317 Posts
well i bought a scangauge2 on amazon so that will solve the temp display problem , should be here the 6th. also i removed the switch panel on the driver side and found that the plug for the passenger windows had disconnected from the panel so its plugged back in lol as for rpm ill try resetting the car, how long does the battery have to be disconnected for? i have a k&n installed and new muffler, maybe that is why the rpm is low. it has not been reset to relearn afr and such.
Disconnect the negative cable, hit the brake pedal a few times, and go plug it back in. Should do the trick much quicker than waiting around on the charge to drain.
 

·
Chevrolet Customer Assistance Representative
Joined
·
5,722 Posts
well i bought a 2012 about 4 months ago and ive noticed a few things wrong

- my dic does not display engine coolent temp, instead i have a blank screen where it should be
- my friend has told me he has seen my drivers side fog light flicker on bumpy road ( cut out and flash )
-and this morning my passenger window does not move or make any noise as if it intended on moving with
no click of the relay
also my engine idles around 500 rpm and i asked members of the fourm by creating a thread and it seems im alittle low compared to others

i only have just under 6000 KM

ive seen on youtube videos that the dic is also supposed to display if traction control is on or not
also ive seen that there are also suposed to be like little tabs on the side of the screen that tell you
what page of the dic you are on for the corrisponding menu.

i have almost every pakage added to my car but nav, tmps, ltz, so im wondering if its only ltz that gets thoes dic features mentioned above?
i have the supervision cluster so shouldent i have it to?

was there a recent update done to the car that i may not have?
i orded my cruze on the last week that we were alowed to place orders for 2012's so i figure i should have all firmware , software, ecu updates ect.....

what are your thoughts?
do you have it too?

also to stacy:

what steps should i take befor bringing my car in and can you tell me if my car is up to date if i give you my vin?

thanks to all in advance

ru5ty :)


ru5ty,
I would recommend that you take your Cruze into your dealer and have them look into your concerns. If you would like you can also contact GM of Canada and get a service request open with them in regards to these concerns prior to you going to the dealer. You can contact them at 800-263-3777 Monday-Friday 7:30am - 11:30pm or Saturday 7:30am - 6:00 EST. Unfortunately I am unable to look up your VIN in my system (I can only look up US VIN's). I am very sorry for this inconvenience to you. Please feel free to keep me posted on this. If you have any other questions please feel free to contact me and I will help you in any way that I can.
Thank you,
Stacy Chevrolet Customer Service
 
1 - 19 of 19 Posts
Top