Chevrolet Cruze Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently had my engine changed in my 2011 Chevy Cruze ( 1.8 ) and when I got it back now my stereo won’t work. The Mylink would show up on the screen but none of the controls would work and wouldn’t do anything else also my blinkers quit making sounds when flashing. Could anyone explain what might have happened I even tried unplugging the fuse for 30 seconds then replacing but still nothing ?????
 

·
Registered
Joined
·
596 Posts
Sounds like something is up with either the BCM (cody control module) or the wiring to it. The BCM control the blinker sounds and I believe the mylink as well. Sound slike whoever did the swap forgot to hook something up
 

·
Premium Member
Joined
·
7,927 Posts
Do check that everything is plugged in. What was replaced? If they replaced some electronic modules, then the VIN that's programmed into the various modules have may not line up and cause things to not work.
 

·
Registered
Joined
·
1 Posts
Do check that everything is plugged in. What was replaced? If they replaced some electronic modules, then the VIN that's programmed into the various modules have may not line up and cause things to not work.
I have the same issue after the alternator repair and MyLink just continuing to blink with its logo over 3 months. Should I teardown driver’s panel to check connections or there is a place where I can get without it?
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,527 Posts
I have the same issue after the alternator repair and MyLink just continuing to blink with its logo over 3 months. Should I teardown driver’s panel to check connections or there is a place where I can get without it?
If you do not have the Pioneer system, you may be able to reach some of it going through the dash cubby hole. Remove the mat and a few screws to get it out to see.
 

·
Premium Member
Joined
·
7,927 Posts
I have the same issue after the alternator repair and MyLink just continuing to blink with its logo over 3 months. Should I teardown driver’s panel to check connections or there is a place where I can get without it?
I'd just pull the radio. It's easier then trying to go though the back.

Make sure all your battery connections are good. The radio is yet another computer in the Cruze. Computers hate bad power.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Does the top screen actually control the whole stereo system? Any suggestions on a Plug and Play head unit that actually has all the rite harnesses out of box because all the plugs just blow my mind
 

·
Registered
Joined
·
596 Posts
Does the top screen actually control the whole stereo system? Any suggestions on a Plug and Play head unit that actually has all the rite harnesses out of box because all the plugs just blow my mind
Check out Crutchfield. Put in your car and the options (with or w/o NAV, with or w/o Pioneer) and they'll list what fits, what harnesses are needed, etc.
 

·
Registered
Joined
·
498 Posts
Does the top screen actually control the whole stereo system? Any suggestions on a Plug and Play head unit that actually has all the rite harnesses out of box because all the plugs just blow my mind
Not only does the screen control the entire stereo system, it also is needed for customizing various other settings in the car.
There aren't any plug and play radios anymore, except for OEM units.

Here is my personal recommendation.
 

·
Registered
Joined
·
272 Posts
Is it possible the BCM module was changed with the engine swap ?
if it was it the cause of the no sound, the programming is wrong for your audio configuration
 
1 - 12 of 12 Posts
Top