Chevrolet Cruze Forums banner

Radio faceplate buttons are mis-calibrated

6959 Views 5 Replies 2 Participants Last post by  ChevyGuy
Dear experts.
My OEM audio system was consists of:
  • 13336630 head unit with RPO code: UYB
  • 12844844G information display
  • 94563276 radio control face plate.

I decided to upgrade this system to another OEM GM system. I get
  • 22815634 head unit with RPO code: U2K + UYE
  • 12783136 information display
  • 95914367 radio control face plate

NOTE: the seller said that the head unit 22815634 is removed from a "Buick Landcrosse 2012", and he said it is compatible with Chevy Cruze.

But unfortunately I get a "LOCKED" message in the display after installing all these new units.

I went to my local dealer for VIN relearn the head unit. But they could not help. I tried myself with a little expert in electronics to inspect the PCB of the 22815634 head unit and search fro the EEPROM which stores the VIN. I removed it, read it, reprogrameed it with my vehicle's VIN

But while I was removing the chip from the PCB, unfortunately a pin is broken :sad: before I read it.

Electronics Green Electronic component Technology Circuit component

Anyway, I tried to read and get the dump file. I don't know is it healthy or corrupted.​
After reading it and found the original donating car's VIN, I replaced it with my vehicle VIN.

Text Line Pattern Font Design

:):):), Lucky am I

It works. The locked message disappeared. and it works fine. All bands, CD are working fine.

The MAIN problem I have now is that all the buttons in the faceplate are mis-calibrated.
Technology Electronic device Electronics Multimedia Audio equipment

I don't know what is the reason for it?

  • Is it the different in RPO code
  • Is it a corrupted dump file read and written in the EEPROM
  • Is it a difference between the pinout connection harness
  • Is it the missing cable of the XM-satellite cable which is not connected.
  • Or something else

Product Technology Electronic device Enclosure Room
Please HELP :question::question::question::question:
1 - 3 of 3 Posts

· Registered
17 Posts
Discussion Starter · #3 ·
First off, if I'm interpreting the pictures properly, you've kept your OEM buttons with the new radio. I don't think that will work.
yub, I am using my existing OEM buttons cause it is have folders navigation buttons. Also I tried the other 95914367, but they are both acting the same way.

How does the buttons connect to the radio? Is it direct or though the car's harness? If though the stock harness, that could be a problem. Any chance the connection is done backwards? I do think the connection is the most likely source of the problem - unless you're running into issues somewhere else.
The buttons are connected through the car's harness. I didn't make any wiring cut or rearrangement

EEPROM. Did you look up the function of the broken pin? That could certainly be an issue. But I'd expect far bigger problems then this if it was a address or data line.
I already had replaced this broken EEPROM with a new one. but the dump was obtained from the broken chip

Another concern is that in the dealer in trying to help you might have flashed the wrong software into the radio. I'm not sure as all dealers know how to work to the system for "user installed upgrades". By default it's probably going to ask for the car's VIN and then the software will deal with the car as if it unchanged.
It may be occurred. But they couldn't remove the locked msg.

But for now, I'd go with the theory of wrong buttons or connection harness. But that could change if you find functions missing, etc.
Any suggestions???, I had mentioned that I still missing the "manual radio tuning" and "AS auto store"
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.