Chevrolet Cruze Forums banner

1 - 10 of 10 Posts

·
Banned
Joined
·
10,296 Posts
Discussion Starter · #1 ·
Typically switch everything off as I pull into my driveway, yesterday I didn't, left the radio on. So while driving, radio was flashing on and off like a railroad crossing signal.

Cure when on was to switch it off. stop the car, switch off the ignition, open the door, wait a couple of seconds, then restart the car with the radio off, then switch it on. Assuming the microcontroller was not properly resetting the programming counter to zero to start the program at the beginning, then it was okay.

If the programmer knew how to program, could written in such a manner for self correcting logic, but dey don't do dis. Just rush to market, always hated this term, rush to market.

No longer a radio, now a computer.
 

·
Premium Member
Joined
·
5,534 Posts
Nick?
Has your car had the negative battery cable replacement yet?

Seems thats how they sign off…..resistance gets high enough that the radio is the first component to 'see' the voltage drop.

Rob
 

·
Premium Member
Joined
·
3,975 Posts
Nick: You're handy with electronics. Would you consider soldering the crimp on the negative battery cable to see if it fixes the problem?
 

·
Administrator
Joined
·
25,596 Posts
If the programmer knew how to program, could written in such a manner for self correcting logic, but dey don't do dis. Just rush to market, always hated this term, rush to market.

No longer a radio, now a computer.
No computer on the market likes to have power cut and restarted quickly. The fact that the Cruze's systems don't go completely berserk when this happens is a testimony of how good GM's software engineers really are.
 

·
Premium Member
Joined
·
3,975 Posts
No computer on the market likes to have power cut and restarted quickly. The fact that the Cruze's systems don't go completely berserk when this happens is a testimony of how good GM's software engineers really are.
When I was a Systems Engineer with that big computer company with the stripped logo, our computer systems had huge power supplies that could run through power fluctuations and short outages without skipping a beat. It was done to reduce the pain on our less than technical entry level users with having to recover after one.
 

·
Banned
Joined
·
10,296 Posts
Discussion Starter · #6 ·
With the radio, off the screen is flashing on and off in very erratic fashion. This is after I posted this, if I switch the radio on when the screen is lit, it works but goes on and off with that flash of the radio screen. Nothing else on the dash is flashing on and off, just the radio. So must be some kind of erratic power source problem.

Not the negative battery cable, caught this problem like about four years ago when I first got this car. Filed that gap for a tight fit, this is how it looks today.

View attachment 165186

Positive terminals, all of them look the same way, nice and clean and greased with silicone.

Could be an erratic connection to the leads running to the radio or the radio itself., but have to put this off. Picked up the flu from one of my grandkids that must have picked it up from school. So feeling very rotten now.

Ran into problems like this not once, but thousands of times, a solder flux connection, corrodes over time causing erratic breaks. Hope the Cruze is not using insulation displacement terminals in the connectors, a real nightmare. Doubt if the radio can be bench tested with all this security crap.

But why now, too sick to do anything.
 

·
Super Moderator
Joined
·
7,787 Posts
Get well soon brother Nick.
 

·
Banned
Joined
·
10,296 Posts
Discussion Starter · #8 ·
Still not feeling all that hot, but tried some simple stuff, like testing the contact resistance of the ignition relay, was considerably higher than an identical relay used for the cooling fan so I switched them. Ignition relay is switching all the time with each cycle, cooling fan relay, least in my Cruze is barely used.

Radio is working okay now, but yet another factor, ambient temperature is cooler today than yesterday. Heat causes expansion, that results in a good contact at cooler temperature that fail at higher temperatures. For now, see what happens.
 

·
Banned
Joined
·
10,296 Posts
Discussion Starter · #9 ·
Put up with this flashing on and off radio for two days, something told me to check the ignition relay contacts, sure enough, was erratic with carbon on the contacts, cleaned those and now as been solid as a rock.

Ha, wonder what would happen if I took my car to the dealer, probably would have charged me 800 bucks for a new radio and a half a days labor to replace it. And it would still flash on and off.

Still fighting this blasted flu, could see a doctor and be charged 500 bucks to be told to get plenty of rest and drink fluids. Have this strange idea, this flu is yet another Chinese import, been getting plenty of these imports.
 

·
Moderator
Joined
·
10,713 Posts
Put up with this flashing on and off radio for two days, something told me to check the ignition relay contacts, sure enough, was erratic with carbon on the contacts, cleaned those and now as been solid as a rock.

Ha, wonder what would happen if I took my car to the dealer, probably would have charged me 800 bucks for a new radio and a half a days labor to replace it. And it would still flash on and off.

Still fighting this blasted flu, could see a doctor and be charged 500 bucks to be told to get plenty of rest and drink fluids. Have this strange idea, this flu is yet another Chinese import, been getting plenty of these imports.
Nope just the neg cable and reset it, that's all I get for my issues.
 
1 - 10 of 10 Posts
Top