Chevrolet Cruze Forums banner

Radio works but screen is blacked out

1979 Views 6 Replies 3 Participants Last post by  Blasirl
Hi all,

Yesterday I bought a used Chevy Cruze 2015 and am having issues turning the display on. The radio works fine. I can control the stations through the buttons, control volume, and I can even hear the sounds o buttons being clicked on when I touch the screen. The display is "turned on" however everything is blacked out, if that makes any sense. Its similar to when a TV is turned on and for a second only a bright "lighted" black screen is seen. This is what I see on the display.
All other buttons on the steering wheel works fine as well.

Would anyone be able to shed some light on what needs to be done to fix this?

Thanks
1 - 7 of 7 Posts

· Premium Member
14 Diesel Cruze, ‘14 volt, ‘72 442
Joined
·
479 Posts
It may just need to be rebooted (fyi, electronics are not my forte). I’d start simple and unplug the battery for 15 minutes or so and hook it back up and check. Otherwise it may need to be reset/programmed to relearn it. Are there any codes at all?
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
It may just need to be rebooted (fyi, electronics are not my forte). I’d start simple and unplug the battery for 15 minutes or so and hook it back up and check. Otherwise it may need to be reset/programmed to relearn it. Are there any codes at all?
No codes unfortunately.
By reset/programmed you mean pulling out the fuse and inserting them again?
 

· Premium Member
14 Diesel Cruze, ‘14 volt, ‘72 442
Joined
·
479 Posts
No, someone like a dealer or mechanic who has a scanner that hooks to you OBD and resets the module that way. If you just bought it, and from a dealer especially, I would take it back and demand they fix it.
 

· Administrator
2014 LT program car, Pull Me Over Red, 1.4T Auto
Joined
·
14,177 Posts
Hi all,

Yesterday I bought a used Chevy Cruze 2015 and am having issues turning the display on. The radio works fine. I can control the stations through the buttons, control volume, and I can even hear the sounds o buttons being clicked on when I touch the screen. The display is "turned on" however everything is blacked out, if that makes any sense. Its similar to when a TV is turned on and for a second only a bright "lighted" black screen is seen. This is what I see on the display.
All other buttons on the steering wheel works fine as well.

Would anyone be able to shed some light on what needs to be done to fix this?

Thanks
This is one possibility:

Blank MyLink Touch Screen (How to Fix)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top