Chevrolet Cruze Forums banner

Random hesitation Cruze LS gen I 2010 1.6L 113 HP

615 Views 2 Replies 2 Participants Last post by  Cruze CTRL
Hello,

I post the car specs below:

Car specs:
Engine: 1.6L petrol 113HP (euro V EU spec)
Transmission: 5 speed manual
Mileage: 84 000 km (52 000 miles)
LHD
Trim level: LS
Country: EU (state: romania)

The issue I'm facing is that randomly the car hesitates, and sometimes it is running rough (stutters during idle), but if I press the gas pedal all the way to the floor the car returns to normal.
Checked it and it does not misfire, this is expected as both spark plugs and the ignition module are new.
I do not think this is an injector issue as it does this on both gasoline and LPG (for LPG it has a different set of injectors).
The check engine light turns on after some time and the code is P0130 (deleted it several times and comes back every time).
The upstream O2 sensor was changed (with a delphi one, rather than OEM one) a few months ago and it was running fine, for some time, but now it developed this issue.
The mechanic told me it may be a wiring issue on the oxygen sensor circuit.
When it does this, looking at the upstream O2 sensor graph, it seem to stay stable at 0.4V but after I press the pedal to the floor it comes back to normal (jumping up and down between 0.2 and 0.9V)
My question is, does somebody know common issues regarding the upstream O2 sensors and hesitations on these cars? Would the P0130 code be the reason of the hesitations? Should I search for a OEM sensor?

Thanks,
Alex
1 - 3 of 3 Posts

· Registered
Joined
·
22 Posts
Discussion Starter · #2 ·
Fixed it. Courtesy of the mechanics from the US and Canada who post youtube videos showing how to properly diagnose car issues (those guys are real professional repair technicians who actually investigate the issue compared to the mechanics in romania who expect the customer to tell them what to change or play the guessing game on his or her money) and the workshop manual which taught me how to handle and change the sensor without breaking it.
Sure enough the oxygen sensor was the culprit, it was a delphi one installed by the service where I've changed the cat. The delphi sensor apparently had a issue with temperature or somethin' as it was misbehavin' when the engine and the cat were hot.
Apparently on these cars, on torque lite app, when the sensor is stuck on 0.4V and has no activity that means there is no signal whatsoever (tested it with ignition on but engine off with the oxygen sensor unplugged).
Bought a original sensor from a junkyard (for 40 euros, a new one was 300 euros) installed it myself, car runs fine, no more P0130 no more hesitations.
What was happening when I was pressing the pedal to the medal and ran fine? simple, that triggered it to run insanely rich (seen it on the downstream oxygen sensor, as it read almost a constant 0.8-0.9V while the pedal was pressed to the absolute floor) but the upstream was still...dead...

Tips and tricks: never ever in any car install a aftermarket oxygen sensor you're guranteed to have problems, in case of problems, grab the sensor and look at what is written on it and buy the exact same one, either brand new either one from a junkyard like I did, don't check the year displacement etc of the donor car, check the part number brand and type, mine has the following written on it (note that yours might be different):

GM 55 566 650
NTK type OZA 619
Continental 5WY2D01A

I've asked the guy at the junkyard for one with the same exact writing and he found it in a 2012 compact cruze 1.6 124HP and mine is a 2010 sedan 1.6 113HP but the part number manufacturer etc was a match, I've installed it and the car runs fine now.
 

· Registered
Joined
·
104 Posts
Thank you for your SOLVED post so many can't be bothered to write up!
This wonderfully designed car, so badly put together, sadly with even some plastic CN toy factory parts, has a lot of diff causes for annoying hesitation. One more added to the collection of horrors 😌
 
1 - 3 of 3 Posts
Top