Chevrolet Cruze Forums banner

Rear defroster / defogger turns off to soon

10062 Views 17 Replies 8 Participants Last post by  Fernando Enciso Contreras
Hello all,

Has anyone experienced their rear defroster / defogger turns off before the frost has been removed? The manual states that it'll run for about 10 mins, then turn off on its own. If you turn it on again, it says it will stay on for only 5 mins. I've timed mine and it only stays on for 6 mins the FIRST time and 3 mins afterwards. Does anyone know if their is a TSB or a way to keep the rear defroster on for longer? Wish they would leave me to control that function, not the computer. Rrr. Very frustrating on the cold days (Ya Canada) when I can't see out the back.
Thanks!
1 - 2 of 2 Posts

· Registered
Joined
·
157 Posts
Hello all,

Has anyone experienced their rear defroster / defogger turns off before the frost has been removed? The manual states that it'll run for about 10 mins, then turn off on its own. If you turn it on again, it says it will stay on for only 5 mins. I've timed mine and it only stays on for 6 mins the FIRST time and 3 mins afterwards. Does anyone know if their is a TSB or a way to keep the rear defroster on for longer? Wish they would leave me to control that function, not the computer. Rrr. Very frustrating on the cold days (Ya Canada) when I can't see out the back.
Thanks!
Hhmm perhaps have a thought, just how cold is it there? (if u can , change to f temp for a states guy :) )
 

· Registered
Joined
·
157 Posts
mornings lately have been around -30C or -22F
Well thats a little cool :) . The reason I asked is because on some GM vehicles around the 2011 time frame (don't know if its continued or applicable) there was something programmed that would not allow ( or perhaps turned off) electric type heat when battery was at 70% capacity or less. I could guess it was a safety feature of sorts to ensure vehicle had nore power to start, but the lack of seat heat and/or rear defrost did not sit well with some.
 
1 - 2 of 2 Posts
Top