Chevrolet Cruze Forums banner

Reduce Power, Searching Idle, DTCs P0068, P0236, P0237, P2227

10168 Views 2 Replies 3 Participants Last post by  Duncanbri23
Hi Guys, my 1.4L turbo has some new problems that I'm hoping you can help me with. On a recent road trip the check engine light came on after a few hours of driving and I noticed reduced power, especially on starting from stop and on uphills. Felt as if the turbo boost wasn't working. Once we got back home I pulled the codes and got the following:

P0236 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Performance
P0237 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Circuit Low Voltage
P2227 (Stored, Pending & Permanent) - Barometric Pressure (BARO) Sensor Performance
P0068 (Stored) - Throttle Body Air Flow Performance

Also, during idle, the engine rpms are "searching" (reving up and down) as if trying to find a steady point. I've done an initial search over the engine and haven't found anything abnormal. Other than the reduced power and searching idle, the car runs fine. Anybody have any hints of where I could search?

Also possibly relevant, I did have an issue the PCV valve previously and installed XtremeRevolution's PCV fix kit (v1) about 21,000 km ago (13,000 miles).

Lastly, I have a scanner with live data so i was going to measure the current MAP I'm getting during heavy acceleration. Does anybody have a reference number of what types of MAP I should be getting if the turbo is working properly?

Thanks for the help.
1 - 3 of 3 Posts

· Registered
Joined
·
87 Posts
Check the turbo charge piping for a blown hose or cracked pipe, It sounds like unmetered air is entering the system and metered air is escaping somewhere. I currently am facing a similar issue, but when I go up hills I blow thick clouds of blue smoke out... My turbo is shot. So I hope you don't have the same issue! haha

*EDIT*

Also, on a stock car, you should be making boost pretty much anytime your accelerating. I've see up to 17-18 PSI MAX on my stock tune.
 

· Registered
Joined
·
4 Posts
Did you ever figure this out
Hi Guys, my 1.4L turbo has some new problems that I'm hoping you can help me with. On a recent road trip the check engine light came on after a few hours of driving and I noticed reduced power, especially on starting from stop and on uphills. Felt as if the turbo boost wasn't working. Once we got back home I pulled the codes and got the following:

P0236 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Performance
P0237 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Circuit Low Voltage
P2227 (Stored, Pending & Permanent) - Barometric Pressure (BARO) Sensor Performance
P0068 (Stored) - Throttle Body Air Flow Performance

Also, during idle, the engine rpms are "searching" (reving up and down) as if trying to find a steady point. I've done an initial search over the engine and haven't found anything abnormal. Other than the reduced power and searching idle, the car runs fine. Anybody have any hints of where I could search?

Also possibly relevant, I did have an issue the PCV valve previously and installed XtremeRevolution's PCV fix kit (v1) about 21,000 km ago (13,000 miles).

Lastly, I have a scanner with live data so i was going to measure the current MAP I'm getting during heavy acceleration. Does anybody have a reference number of what types of MAP I should be getting if the turbo is working properly?

Thanks for the help.
Hi Guys, my 1.4L turbo has some new problems that I'm hoping you can help me with. On a recent road trip the check engine light came on after a few hours of driving and I noticed reduced power, especially on starting from stop and on uphills. Felt as if the turbo boost wasn't working. Once we got back home I pulled the codes and got the following:

P0236 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Performance
P0237 (Stored, Pending & Permanent) - Turbocharger Boost Sensor Circuit Low Voltage
P2227 (Stored, Pending & Permanent) - Barometric Pressure (BARO) Sensor Performance
P0068 (Stored) - Throttle Body Air Flow Performance

Also, during idle, the engine rpms are "searching" (reving up and down) as if trying to find a steady point. I've done an initial search over the engine and haven't found anything abnormal. Other than the reduced power and searching idle, the car runs fine. Anybody have any hints of where I could search?

Also possibly relevant, I did have an issue the PCV valve previously and installed XtremeRevolution's PCV fix kit (v1) about 21,000 km ago (13,000 miles).

Lastly, I have a scanner with live data so i was going to measure the current MAP I'm getting during heavy acceleration. Does anybody have a reference number of what types of MAP I should be getting if the turbo is working properly?

Thanks for the help.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top