Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Let me start by stating this is my 1st GM product and am greatly regretting that decision while I do love comfort an power of my cruze the customer service is pitiful. For the past few months I have been getting a check engine light about every 2 1/2 weeks on my 14 for NOX sensor 2 light ive been to a few different dealerships and they all have done the same thing start with cleaning plug and next time changing the sensor and then the next time changing all of the sensors in the exhaust with no resolve ive contacted GM twice about the issue and they just keep moving me to different dealerships and saying that dealers are their own entity and cant really do much else I thought I bought a GM vehicle with a GM warranty and all their hype about quality to be backed and supported by GM to resolve any issue I had to ensure I buy another GM product but apparently I was wrong and GM is done with you the second you drive it off the lot coming from Ford where every issue ive ever had is addressed timely and ensure my satisfaction as a customer this is just baffling to me that they refuse to stand behind their product and refuse to have an engineer involved even thou it is still under warranty and are just trying to run me out of it so it Is no longer their problem. So my question is has anyone else been having similar issues?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Thanks for all the replys so far guys. power and milage are the same. I had the 1st recall for the #1 sensor done in November of last year had no issues till a end of march this year. the 1st time they reset the calibrations and fuel trim incase they forgot the when they did the recall. 2nd time they cleaned the connections and sensor claiming there was moisture in the plug. The next time they replaced the sensor n reset calibrations. then they replaced all senors in the entire exhaust system. then I called GM they sent me to another dealer so I went they said GM TSB says it could be from short trips and asked if make frequent short trips which I don't I live in the country half hour from town and being familiar with modern diesels coking up with short trip by not getting hot enough I never do. While it was there since I don't take short trips they did the same thing as the last dealer and replaced all sensors and preformed the newest recall afterwards while they still had it and right after performing recall sensor 1 popped codes so it got replaced twice there. And now another 2 1/2 weeks out I get a light for sensor 2 again and contact GM got the same run around and goes back in Monday. Also filed complaint with BBB auto per owners manual being so close to running out of warranty and being already told its not GMs problem after since im clearly not getting any resolution thus far. How do I find out if the dealer filed a GM-TAC
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top