Chevrolet Cruze Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hey guys, new to cruze forums and first post.

My 2011 Cruze Eco (Standard Transmission) has been rough idling lately and today it stalled while I was at a light. It has 75k miles. I had to restart it and it started with no problem. It also has no big issues while driving. Check engine light came on a few days ago, about when the rough idling started.Any thoughts on what it could be?
 

·
Administrator
Joined
·
25,040 Posts
Welcome. This sounds like the PCV valve cover. My 2012 ECO MT had the same issue last summer. GM has a new and hopefully more robust design for the springs in this valve.
 

·
Premium Member
Joined
·
890 Posts
Yes the cause is most likely a leaking valve cover. It should be under warranty. I suggest taking it into the dealer and having them replace it. This is a very simple repair and nothing major at all but it needs to be fixed asap.
 

·
Chevrolet Customer Assistance Representative
Joined
·
5,722 Posts
Hey guys, new to cruze forums and first post.

My 2011 Cruze Eco (Standard Transmission) has been rough idling lately and today it stalled while I was at a light. It has 75k miles. I had to restart it and it started with no problem. It also has no big issues while driving. Check engine light came on a few days ago, about when the rough idling started.Any thoughts on what it could be?
Hi Druiz1,

The others have provided excellent feedback, but let me know if you need an extra layer of assistance into the dealership. I'm always happy to help the best way possible. Feel free to send me a private message along with your VIN, current mileage, contact information and preferred dealership. Looking forward to your updates!

Patsy G
Chevrolet Customer Care
 
1 - 4 of 4 Posts
Top