Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
My right module went out about a year ago. When they looked at it and told me what it would cost to fix it I declined to have it fixed. When I left I realize my infotainment center was completely black. I turned around and took the car back and they had it for two days. They insist that it has absolutely nothing to do or any connection in anyway with the right module.they said the problem was caused by wire in the Dash grounding out. Now I have it back in again because the check airbag light came on and then the seat warmers didn't work and then the pushbutton start didn't work after I got it to the dealer. They started it manually and then couldn't get the key out of the ignition. I called today to check on it and they told me everything is fixed except the seat warmers. I asked what the problem was and they told me oh just a wire shorting out. They are checking the seat warmers because now they think the seat warmers are also controlled by that right module that I didn't replace. Does anyone know if that's the case? Oh..and I did want to know if they are correct about the module ad the infotainmentcenter being completely separate
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
10,383 Posts
Welcome Back!:welcome:

I have not experienced any of that so I'm no help, but someone might chime in with a similar issue and hopefully a solution.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks. I realized I posted it in wrong place. I have Aldo posted it on appropriate forum. No responses yet
 
1 - 3 of 3 Posts
Top