Chevrolet Cruze Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I searched forums and User Manual, but couldn't find this anywhere so hoping someone has a clue!
I have a small half-round sensor with flat front and back, pattern of small holes on top, wired-in on the driver's side on top of dash. The right and left halves light-up separately, so it's a quarter-circle light (red), then there's an outer light (also independent) on that "quarter" that's yellow. They work independently but can both come on at the same time. Picture of the unlit sensor is attached - that's frost on the windshield (maybe that's a clue?).

It doesn't appear to be a custom item, but I bought my 2014 used. For six months I barely noticed it, but then while driving, the lights came on with a loud steady beep.

In my search I saw something related to windshield wipers and automatic lights, which may have been on when this happened, but I leave my lights on "auto" so not sure why this was first time.

Any help is appreciated!
 

Attachments

·
Premium Member
Joined
·
5,535 Posts
It may be an alarm but it definately is not a factory part.

Some of the used car lots put something on the car to help find it (or disable it) if a repossetion is required......might be something they failed to remove.

I think I would stop at the used car dealer first and ask......if negative, then I'd stop by anyplace that installs alarms to see if the can identify it.

Rob
 

·
Premium Member
Joined
·
3,975 Posts
I'm with Robby. Was your car a rental in a previous life perhaps. My money is on the "repo" circuitry. Curious, how many miles on the odo?
 

·
Premium Member
Joined
·
8,003 Posts
Possible, but I like Keyzbum's idea of a aftermarket park assist or blind spot warning. Might want to pay attention to when it lights up and beeps.
 
1 - 5 of 5 Posts
Top