Chevrolet Cruze Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I got a new key and did the 30 minute program and the car started and idled fine. Few minutes later the "Service Theft Deterrent System" was displayed in the information center and the car died. I tried programming the key again, but after 10 minutes the security light just stays on. It will crank, but the engine does not fire/start/run.

Anyone know where I might look?

No warranty on car.
 

·
Administrator
2014 LT program car, Pull Me Over Red
Joined
·
12,105 Posts
I got a new key and did the 30 minute program and the car started and idled fine. Few minutes later the "Service Theft Deterrent System" was displayed in the information center and the car died. I tried programming the key again, but after 10 minutes the security light just stays on. It will crank, but the engine does not fire/start/run.

Anyone know where I might look?

No warranty on car.

No warranty on a Gen II? Must be pretty high mileage on her.

If the key programming is the same as a Gen I, it takes about 10 seconds to program. Where did you get your instructions from?
 

·
Super Moderator
Joined
·
7,804 Posts
Flood car. Salvage title.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Yes, Salvage title. 5000 miles on car.

It appears the theft deterrent system is shutting down the fuel pump according to my scan tool.

Went out after it sat for about 8 hours and it started up no problem and idled for some time before it died again.

Something is shutting down fuel, which certainly appears related to the "Service Theft Deterrent System" message on the information center. This fuel pressure is very random.

Is it correct that the BCM controls the Theft Deterrent System and fuel pump/spark? If this is so, then I will start looking into the BCM as the culprit.

Locksmith told me about the programming procedure. After the 30 minute procedure the info center stated "1 Key Programmed" and it started up no problem. After a few minutes the Theft System message displayed.
 

·
Premium Member
Joined
·
8,003 Posts
Does it have the problem with the original key? I'd suspect some kind of problem where the systems can't talk to each other so they shut down. Or you're having a power interruption so the car comes back in a funny state.
 
  • Like
Reactions: Tomko

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 · (Edited)
Don't have the original key. Programmed the new key via the 3-10minute intervals and it started fine. Now I have an intermittent start and it only runs for a few seconds then dies. When it doesn't start I lose fuel pressure and spark. I also have the security warning "Service Theft Deterrent System" message.

Is it the PCM or the BCM that is causing the message to be displayed?
 

·
Premium Member
Joined
·
8,003 Posts
I thumbed though the section on the immobilizer - a lot of stuff that can go wrong. If you've changed any of the modules, that could be an issue. Even an wrong key type can be an issue. Most of the stuff listed indicates starting is disabled. There was only one situation where it would shutdown after starting - and that was after some challenge/response between the BCM and ECM failed.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
I thumbed though the section on the immobilizer - a lot of stuff that can go wrong. If you've changed any of the modules, that could be an issue. Even an wrong key type can be an issue. Most of the stuff listed indicates starting is disabled. There was only one situation where it would shutdown after starting - and that was after some challenge/response between the BCM and ECM failed.
Thanks for checking for me. I did get a 4 button key. The FOB buttons all operate fine. Information center stated "1 Key Programmed" after the 30 minute procedure. Car ran and idled for 2-3 minutes when first started then started this sporadic "service theft..." message. It starts about every 7 attempts and then dies of curse after a brief period of time. It dies immediatley if you try to give it gas, otherwise it will idle on it's own for a little longer. Also does better if left alone over night unplugged.

The Convert Power Supply was changed, but I can't find anything on that to see if it would need programmed.
 
1 - 8 of 8 Posts
Top