Chevrolet Cruze Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I am having an issue with my Cruze right now with the song skipping like a scratched cd. I started doing this just recently and not sure why. Just wondering if anyone else has run into this.
 

·
Administrator
Joined
·
25,596 Posts
Have you restarted your phone? When my Bluetooth starts doing this I know my phone is getting ready to crash.
 

·
Registered
Joined
·
306 Posts
My car does this at times, and my previous FR-S did as well, when first starting up the car and it has just connected to BT, it will skip like that for up to minute after playing a song asap.
 

·
Premium Member
Joined
·
3,177 Posts
If it's the same thing I've experienced from time to time when playing music over bluetooth, the Mylink Infotainment Team told me to close all other apps that are open on my phone and once I do that, then it should eliminate the problem or help keep it from happening.

When I asked about it possibly being caused from poor/average cell phone coverage, he said that that shouldn't cause the problem. I'm not sure exactly how it could not? I've always noticed on my iphone 5 that it's when I see a "loading/buffering" circle up in the corner somewhere that the song skipping through bluetooth tends to happen.

The iphone's current ios and the Mylink's bluetooth certainly don't seem to play nice together, but when I talked to a Mylink Infotainment Team member, he said that both GM and Apple are aware of the issues and that they should be fully resolved within the next 1 or 2 ios updates that Apple will be releasing.
 

·
Registered
Joined
·
306 Posts
If it's the same thing I've experienced from time to time when playing music over bluetooth, the Mylink Infotainment Team told me to close all other apps that are open on my phone and once I do that, then it should eliminate the problem or help keep it from happening.

When I asked about it possibly being caused from poor/average cell phone coverage, he said that that shouldn't cause the problem. I'm not sure exactly how it could not? I've always noticed on my iphone 5 that it's when I see a "loading/buffering" circle up in the corner somewhere that the song skipping through bluetooth tends to happen.

The iphone's current ios and the Mylink's bluetooth certainly don't seem to play nice together, but when I talked to a Mylink Infotainment Team member, he said that both GM and Apple are aware of the issues and that they should be fully resolved within the next 1 or 2 ios updates that Apple will be releasing.
Do you have the new iOS9? Didnt it just come out? I would figure that would fix the problem then.
 

·
Premium Member
Joined
·
3,177 Posts
Do you have the new iOS9? Didnt it just come out? I would figure that would fix the problem then.
Yeah, my iphone 5 has the iOS 9.2.1 update, but from what I was told, it's this iOS that caused much of the problems we're seeing with the Mylink's bluetooth.
 

·
Premium Member
Joined
·
8,003 Posts
In addition to what has been said, keep in mind what else may be running on your Bluetooth - perhaps a smart watch, fitness band or anything else that may be in the car with you.
 

·
Registered
Joined
·
306 Posts
Yeah, my iphone 5 has the iOS 9.2.1 update, but from what I was told, it's this iOS that caused much of the problems we're seeing with the Mylink's bluetooth.
Oh, that's too bad.. I'm sure they will update it to fix it soon.

Unfortunately, I feel like every time iOS updates, as well as my Mac, It gets slower/has more problems =/

This was a major reason why I went from iphone 5 to Galaxy Note 4, and it had been one of the best choices I have ever made.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #10 ·
My car is a 2014 model and my phone is the Note 5, I have tried restarting it, powering it down for a minute and turning back on and even clearing out the apps that are active and it still does it. Kinda strange since I have had the car for a year now and this problem just started 4 days ago.
 

·
Registered
Joined
·
60 Posts
MP3s do not skip, that isn't how it works. Either your BT connection is going in and out, or your head unit is overloaded (processor is struggling)
 

·
Conservative Acoustic Foam
Joined
·
1,028 Posts
Keep in mind that when your phone first connects, your address book is syncing up to MyLink so you can use voice commands to call people, etc. And that's only the most obvious thing that happens...there is probably more syncing than that.

All that handshaking and data transfer eat away at the bandwidth available. So until it's done, audio streaming will suffer in the form of stuttering and "skipping" (which is just lost packets of data that got bumped out for higher priority data from the sync).

If your audio is still stuttering a couple of minutes after the initial sync, then I would agree with someone above who suggested your phone may be trying to access too many devices at once. AFAIK (not a Bluetooth expert), a master device (in this case your phone) can be connected to up to 7 slave devices, but can only access them one at a time. Theoretically switching is done fast enough that you won't notice, but if it's attempting to stream across multiple channels I can imagine there being some interruptions.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top